qtcreator.pro 1.2 KB
Newer Older
Eike Ziller's avatar
Eike Ziller committed
1 2
include(qtcreator.pri)

3
#version check qt
Eike Ziller's avatar
Eike Ziller committed
4
!minQtVersion(4, 7, 4) {
5
    message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
Eike Ziller's avatar
Eike Ziller committed
6
    error("Use at least Qt 4.7.4.")
7 8
}

Daniel Molkentin's avatar
Daniel Molkentin committed
9
include(doc/doc.pri)
10

con's avatar
con committed
11 12 13
TEMPLATE  = subdirs
CONFIG   += ordered

14
SUBDIRS = src share lib/qtcreator/qtcomponents
15
unix:!macx:!isEmpty(copydata):SUBDIRS += bin
Eike Ziller's avatar
Eike Ziller committed
16 17

OTHER_FILES += dist/copyright_template.txt \
18
    $$files(dist/changes-*)
19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36

macx {
    APPBUNDLE = "$$OUT_PWD/bin/Qt Creator.app"
    deployqt.commands = macdeployqt "$${APPBUNDLE}" \
        -executable="$${APPBUNDLE}/Contents/MacOS/qmlpuppet.app/Contents/MacOS/qmlpuppet" \
        -executable="$${APPBUNDLE}/Contents/Resources/qtpromaker" \
        -executable="$${APPBUNDLE}/Contents/MacOS/qmlprofiler"
    deployqt.depends = default
    bindist.commands = 7z a -mx9 $$OUT_PWD/qtcreator$(INSTALL_POSTFIX).7z "$$OUT_PWD/bin/Qt Creator.app/"
} else {
    deployqt.commands = $$PWD/scripts/deployqt.py -i $(INSTALL_ROOT)
    win32:deployqt.commands ~= s,/,\\\\,g
    deployqt.depends = install
    bindist.commands = 7z a -mx9 $$OUT_PWD/qtcreator$(INSTALL_POSTFIX).7z $(INSTALL_ROOT)
    win32:bindist.commands ~= s,/,\\\\,g
}
bindist.depends = deployqt
QMAKE_EXTRA_TARGETS += deployqt bindist