• Tobias Hunger's avatar
    Preserve invalid Qt versions when loading a project · d1c23f58
    Tobias Hunger authored
    Now that we have 2.0 out we can be less strict when checking
    project consistency when loading .user files.  The strictness
    was necessary due to upgrading non-target projects to target
    projects.
    
     * Allow for invalid Qt versions when loading a .user file that was not
       updated from the pre-target era.
     * Update the UI to show invalid Qt versions as invalid. Remove
       the Invalid version as soon as a valid one is imported.
    
    This does preserve the buildsteps, too.
    d1c23f58