Commit 134a6988 authored by Leena Miettinen's avatar Leena Miettinen
Browse files

Doc: Qt support on devices

Change-Id: Ida0eea494e3362a7dcf1df9dd5ac915c61af2524
Reviewed-on: http://codereview.qt-project.org/5018

Reviewed-by: default avatarQt Sanity Bot <qt_sanity_bot@ovi.com>
Reviewed-by: default avatarLeena Miettinen <riitta-leena.miettinen@nokia.com>
parent fdee7d28
......@@ -5717,7 +5717,8 @@
\list 1
\o Select \gui Projects to select the Qt version to build the
application. For more information, see \l{Supported Configurations}.
application. For more information, see
\l{Selecting Qt Versions in Qt Creator}.
\o Select the \gui {Symbian Device} build target for your project.
......
......@@ -64,9 +64,10 @@
You can run Qt applications on Symbian devices if the software that Qt
applications require (typically Qt, Qt Mobility, QtWebkit, and Open C) is
installed on the device. On Symbian^3 and later devices, some version of Qt
is pre-installed. On earlier devices, you must install the modules that Qt
applications require. For more information, see
\l{Installing Required Applications on Devices}.
is pre-installed. To deploy applications to earlier devices, you can package
the application with Nokia Smart Installer for Symbian to automatically
install the modules that Qt applications require. For more information, see
\l{Qt on Symbian Devices}.
To run and debug applications on Symbian devices from Qt Creator, you must
install the CODA on-device debugging agent on the device. For more
......@@ -87,7 +88,7 @@
\if defined(qcmanual)
\l{Building with Remote Compiler}.
\else
\l{http://doc.qt.nokia.com/qtcreator-snapshot/creator-remote-compiler.html}
\l{http://doc.qt.nokia.com/qtcreator/creator-remote-compiler.html}
{Building with Remote Compiler}.
\endif
......@@ -103,7 +104,7 @@
\endif
\section1 Installing Required Applications on Devices
\section1 Qt on Symbian Devices
Generally, when developing for Symbian^3 or later devices, you do not need
to install Qt on devices. However, you might want to upgrade or downgrade
......@@ -115,9 +116,9 @@
\note Earlier Qt for Symbian versions, such as Qt 4.6.3 for Symbian, are
only available in the \QSDK online installer. For more information, see
\if defined(qcmanual)
\l{http://doc.qt.nokia.com/sdk-1.1/sdk-installing.html}{Installing Qt SDK}.
\l{http://doc.qt.nokia.com/sdk/sdk-installing.html}{Installing Qt SDK}.
\else
{Installing Qt SDK}.
\l{Installing Qt SDK}.
\endif
......@@ -125,7 +126,8 @@
\list
\o Symbian Belle devices contain Qt 4.7.4 libraries as part of device
\o Symbian Belle devices contain Qt 4.7.4 and Qt Mobility 1.2.1
libraries as part of device
firmware (ROM). To upgrade the Qt version, update the device
firmware. You cannot downgrade the Qt version on Belle devices.
......@@ -135,14 +137,26 @@
not overwritten. It is eclipsed by the installed Qt on the C: drive.
\endomit
\o Symbian Anna devices have Qt 4.7.3 pre-installed.
\o Symbian Anna devices have Qt 4.7.3 and Qt Mobility 1.1.3
pre-installed.
\o Symbian^3 devices have Qt 4.6 pre-installed.
\o Symbian^3 devices have Qt 4.6.3 pre-installed, but they do not have
Qt Mobility libraries pre-installed. If you use Qt Mobility features
in your application, package the application with Nokia Smart
Installer for Symbian to have the necessary dependencies installed
automatically.
\o S60 5th Edition and later devices support Qt 4.6.3 and 4.7.3.
\o Symbian^1 (S60 5th Edition) devices support Qt 4.6.3 and 4.7.3, but
it is not pre-installed to them. Package Qt applications with Nokia Smart
Installer for Symbian to have the latest Qt and Qt Mobility versions
that the device supports installed to the device.
\o S60 3rd Edition feature pack 1 and later devices support Qt 4.6 for
Symbian through Nokia Smart Installer for Symbian.
\note As an exception, the Nokia C6-00 PR4 has Qt 4.7.3 and Qt
Mobility 1.1.3 preinstalled.
\o S60 3rd Edition feature pack 1 and later devices support Qt 4.6, but
it is not pre-installed to them. Package Qt applications with Nokia
Smart Installer for Symbian.
\endlist
......@@ -161,7 +175,7 @@
Installer support in Qt applications, see
\l{http://www.developer.nokia.com/Community/Wiki/Nokia_Smart_Installer_for_Symbian}{Nokia Smart Installer for Symbian}.
\section2 Supported Configurations
\section2 Selecting Qt Versions in Qt Creator
When you select the Qt version to build the application with, consider
which version provides the application with the widest support on different
......@@ -169,61 +183,75 @@
that applications that are built against Qt 4.6.3 also run on Qt 4.7.3.
Similarly, applications that are supported on S60 5th Edition are also
supported
on Symbian^3. However, dependencies, such as QML or Qt Mobility API
on Symbian^3. However, dependencies, such as Qt Quick or Qt Mobility API
versions might restrict the choice of Qt versions that you have.
In general, if you use only Qt widgets and APIs in the application, you
In general, if you use only Qt 4.6 APIs in the application, you
can use \gui {Qt 4.6.3 for Symbian^1} to build it.
The application is supported on both Symbian^1 and Symbian^3 devices.
If you use QML in the application, you can use \gui {Qt 4.7.3 for
If you use Qt Quick in the application, you can use \gui {Qt 4.7.3 for
Symbian^1} to build it. The application is supported on both Symbian^1 and
Symbian^3 devices.
If you use native Symbian APIs, you must check that they are available on
the target devices. For more information about the API differences between
Symbian^1 (S60 5th Edition) and Symbian^3, see the \bold {Symbian
Symbian^1 and Symbian^3, see the \bold {Symbian
Reference Documentation for Qt}, which is delivered together with \QSDK
and which you can view in the \gui Help mode.
You can use a set of ready-made UI components called Qt Quick Components
for Symbian that enforce a Nokia UI look and feel.
\omit
\note We recomment that you use Qt Quick Components version 1.1, because
they contain usability and other improvements. The same set of devices
supports both 1.0 and 1.1.
\endomit
The following table summarizes the supported configurations for each Qt
version available in Qt Creator build settings:
\table
\header
\i Qt Version
\i QML
\i Qt Quick
\i Qt Quick Components
\i Qt Mobility Version
\i Native Symbian C++ APIs
\i Open GL
\row
\i Qt 4.6.3 for Symbian^1 (S60 5th Edition)
\i No
\i No
\i 1.0.2
\i No
\i No
\row
\i Qt 4.6.3 for Symbian^3
\i No
\i No
\i 1.0.2
\i Yes
\i No
\row
\i Qt 4.7.3 for Symbian^1
\i Yes
\i 1.0
\i No
\i 1.1.3
\i No
\i No
\row
\i Qt 4.7.3 for Symbian^3
\i Yes
\i 1.0
\i Yes \omit 1.0 \endomit
\i 1.1.3
\i Yes
\i Yes
\row
\i Qt 4.7.4 for Symbian Belle
\i Yes
\i 1.2
\i 1.1
\i Yes \omit 1.1 \endomit
\i 1.2.1
\i Yes
\i Yes
\endtable
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment