Commit 1911530f authored by Eike Ziller's avatar Eike Ziller
Browse files

Mac/Qt4: Allow compilation with macx-clang mkspec too



Change-Id: I91752859f790b5576db7ec8678c58924f643187c
Reviewed-by: default avatarChristian Stenger <christian.stenger@digia.com>
parent 59a02659
......@@ -10,7 +10,11 @@ isEqual(QT_MAJOR_VERSION, 5) {
CONFIG += c++11
} else {
macx {
!macx-clang-libc++: error("You need to use the macx-clang-libc++ mkspec to compile Qt Creator (call qmake with '-spec unsupported/macx-clang-libc++')")
!macx-clang*: error("You need to use the macx-clang or macx-clang-libc++ mkspec to compile Qt Creator (call qmake with '-spec unsupported/macx-clang')")
QMAKE_CFLAGS += -mmacosx-version-min=10.7
QMAKE_CXXFLAGS += -std=c++11 -stdlib=libc++ -mmacosx-version-min=10.7
QMAKE_OBJECTIVE_CXXFLAGS += -std=c++11 -stdlib=libc++ -mmacosx-version-min=10.7
QMAKE_LFLAGS += -stdlib=libc++ -mmacosx-version-min=10.7
} else:linux-g++* {
QMAKE_CXXFLAGS += -std=c++0x
} else:linux-icc* {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment