Commit 1f842374 authored by Tobias Hunger's avatar Tobias Hunger

Qt4Project: Filter kits in unconfigured projects

Only show those kits with Qt versions

Change-Id: I1076eece172f495e9eb33193da697564ffaea804
Reviewed-by: default avatarDaniel Teske <daniel.teske@digia.com>
parent c977562b
......@@ -38,6 +38,7 @@
#include <coreplugin/icore.h>
#include <coreplugin/modemanager.h>
#include <coreplugin/coreconstants.h>
#include <qtsupport/qtkitinformation.h>
#include <projectexplorer/kit.h>
#include <projectexplorer/kitmanager.h>
......@@ -101,6 +102,7 @@ TargetSetupPageWrapper::TargetSetupPageWrapper(ProjectExplorer::Project *project
setLayout(layout);
m_targetSetupPage = new TargetSetupPage(this);
m_targetSetupPage->setRequiredKitMatcher(new QtSupport::QtVersionKitMatcher);
m_targetSetupPage->setUseScrollArea(false);
m_targetSetupPage->setImportSearch(true);
m_targetSetupPage->setProFilePath(project->document()->fileName());
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment