Commit 271794fb authored by Christian Kandeler's avatar Christian Kandeler

Remove some superfluous QT_VERSION_CHECKs.

5.4.0 is required these days.

Change-Id: I0dc4c788b058f4c3fd2b9026fd7d6c7ab2840884
Reviewed-by: default avatarhjk <hjk@theqtcompany.com>
parent d9e11e8d
......@@ -311,9 +311,7 @@ MimeMagicRule::MimeMagicRule(MimeMagicRule::Type theType,
case RegExp:
d->regexp.setPatternOptions(QRegularExpression::MultilineOption
| QRegularExpression::DotMatchesEverythingOption
#if QT_VERSION >= QT_VERSION_CHECK(5, 4, 0)
| QRegularExpression::OptimizeOnFirstUsageOption
#endif
);
d->regexp.setPattern(QString::fromUtf8(d->value));
if (!d->regexp.isValid()) {
......
......@@ -62,12 +62,7 @@ void tst_fileutils::parentDir_data()
QTest::newRow("//") << "//" << "" << "";
QTest::newRow("/tmp/dir") << "/tmp/dir" << "/tmp" << "";
QTest::newRow("relative/path") << "relative/path" << "relative" << "";
QTest::newRow("relativepath") << "relativepath" << "."
#if QT_VERSION < QT_VERSION_CHECK(5, 4, 0)
<< "see QTBUG-23892";
#else
<< "";
#endif
QTest::newRow("relativepath") << "relativepath" << ".";
// Windows stuff:
#ifdef Q_OS_WIN
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment