Commit 326d40dd authored by Robert Loehning's avatar Robert Loehning

Squish: Parse qtcreator.pro with Qt 5.6 to avoid changing results

Change-Id: I47cecb8ac8aaf1d5a845b801ff4038b3f023a220
Task-number: QTCREATORBUG-17577
Task-number: QTCREATORBUG-17609
Reviewed-by: Christian Stenger's avatarChristian Stenger <christian.stenger@qt.io>
parent 2def9537
......@@ -41,7 +41,7 @@ def main():
waitFor("runButton.enabled", 30000)
# Starting before opening, because this is where Creator froze (QTCREATORBUG-10733)
startopening = datetime.utcnow()
openQmakeProject(pathCreator, Targets.DESKTOP_531_DEFAULT)
openQmakeProject(pathCreator, Targets.DESKTOP_561_DEFAULT)
# Wait for parsing to complete
startreading = datetime.utcnow()
waitFor("runButton.enabled", 300000)
......@@ -62,12 +62,15 @@ def main():
if not test.verify(object.exists(":Qt Creator_Core::OutputWindow"),
"Did the General Messages view show up?"):
openGeneralMessages()
# Verify messages appear once, from using default kit before configuring
generalMessages = str(waitForObject(":Qt Creator_Core::OutputWindow").plainText)
test.verify("Project MESSAGE: Cannot build Qt Creator with Qt version 5.3.1." in generalMessages,
"Warning about outdated Qt shown?")
test.verify("Project ERROR: Use at least Qt 5.5.0." in generalMessages,
"Minimum Qt version shown?")
test.compare(generalMessages.count("Project MESSAGE: Cannot build Qt Creator with Qt version 5.3.1."), 1,
"Warning about outdated Qt shown?")
test.compare(generalMessages.count("Project ERROR: Use at least Qt 5.5.0."), 1,
"Minimum Qt version shown?")
# Verify that qmljs.g is in the project even when we don't know where (QTCREATORBUG-17609)
selectFromLocator("p qmljs.g", "qmljs.g")
# Now check some basic lookups in the search box
selectFromLocator(": Qlist::QList", "QList::QList")
test.compare(wordUnderCursor(waitForObject(":Qt Creator_CppEditor::Internal::CPPEditorWidget")), "QList")
......
......@@ -2683,8 +2683,6 @@
"qmljsgrammar.cpp" "6"
"qmljslexer.cpp" "6"
"qmljsparser.cpp" "6"
"Other files" "5"
"qmljs.g" "6"
"Headers" "4"
"jsoncheck.h" "5"
"persistenttrie.h" "5"
......@@ -2760,9 +2758,6 @@
"qmljsutils.cpp" "5"
"qmljsvalueowner.cpp" "5"
"qmljsviewercontext.cpp" "5"
"Other files" "4"
"parser" "5"
"qmljs.g" "6"
"qtcreatorlibrary" "3"
"qtcreatorlibrary.pri" "4"
"qmljs_dependencies" "4"
......@@ -13819,8 +13814,6 @@
"qmljsgrammar.cpp" "8"
"qmljslexer.cpp" "8"
"qmljsparser.cpp" "8"
"Other files" "7"
"qmljs.g" "8"
"Headers" "6"
"jsoncheck.h" "7"
"persistenttrie.h" "7"
......@@ -13896,9 +13889,6 @@
"qmljsutils.cpp" "7"
"qmljsvalueowner.cpp" "7"
"qmljsviewercontext.cpp" "7"
"Other files" "6"
"parser" "7"
"qmljs.g" "8"
"qttest" "5"
"qttest.pri" "6"
"qtcreator" "6"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment