Commit 384d5d75 authored by BogDan Vatra's avatar BogDan Vatra Committed by Daniel Teske

AndroidConfig::bestNdkPlatformMatch: Ensure that api level 9 is minimum

Change-Id: I527c7ce13b01f441183940a5e0ea2baec64c04e3
Reviewed-by: default avatarBogDan Vatra <bogdan@kde.org>
parent 381b04fa
......@@ -840,6 +840,7 @@ QString AndroidConfig::bestNdkPlatformMatch(const QString &targetAPI) const
{
updateNdkInformation();
int target = targetAPI.mid(targetAPI.lastIndexOf(QLatin1Char('-')) + 1).toInt();
target = std::max(9, target);
foreach (int apiLevel, m_availableNdkPlatforms) {
if (apiLevel <= target)
return QString::fromLatin1("android-%1").arg(apiLevel);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment