Commit 3dd01946 authored by Tobias Hunger's avatar Tobias Hunger

Fix MSVC version for 6.x Windows SDKs

&.0 is using MSVC2005, all later versions starting with 6.0a are
using MSVC2008.
parent 5a186cea
......@@ -103,16 +103,18 @@ static Abi findAbiOfMsvc(MsvcToolChain::Type type, MsvcToolChain::Platform platf
QString msvcVersionString = version;
if (type == MsvcToolChain::WindowsSDK) {
if (version.startsWith("7."))
msvcVersionString = "10.0";
else if (version.startsWith("6.1"))
msvcVersionString = "9.0";
if (version.startsWith(QLatin1String("7.")))
msvcVersionString = QLatin1String("10.0");
else if (version.startsWith(QLatin1String("6.1"))
|| (version.startsWith(QLatin1String("6.0")) && version != QLatin1String("6.0")))
// The 6.0 SDK is shipping MSVC2005, Starting at 6.0a it is MSVC2008.
msvcVersionString = QLatin1String("9.0");
else
msvcVersionString = "8.0";
msvcVersionString = QLatin1String("8.0");
}
if (msvcVersionString.startsWith("10."))
if (msvcVersionString.startsWith(QLatin1String("10.")))
flavor = Abi::WindowsMsvc2010Flavor;
else if (msvcVersionString.startsWith("9."))
else if (msvcVersionString.startsWith(QLatin1String("9.")))
flavor = Abi::WindowsMsvc2008Flavor;
else
flavor = Abi::WindowsMsvc2005Flavor;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment