Commit 49707ff3 authored by BogDan Vatra's avatar BogDan Vatra

Android: Check if DebugDeployment is usable.

It might happen when the user changes the kit from Qt 5.4 to Qt 5.3.

Change-Id: Ib9597ac0189bdc1ac4e82ac8b5de5e090f09283e
Reviewed-by: default avatarDaniel Teske <daniel.teske@digia.com>
parent 3e927272
......@@ -84,7 +84,11 @@ AndroidBuildApkStep::AndroidBuildApkStep(ProjectExplorer::BuildStepList *parent,
m_openPackageLocation(other->m_openPackageLocation),
m_buildTargetSdk(other->m_buildTargetSdk)
{
const QtSupport::BaseQtVersion *version = QtSupport::QtKitInformation::qtVersion(target()->kit());
if (version->qtVersion() < QtSupport::QtVersionNumber(5, 4, 0)) {
if (m_deployAction == DebugDeployment)
m_deployAction = BundleLibrariesDeployment;
}
}
bool AndroidBuildApkStep::init()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment