Commit 5234307c authored by David Schulz's avatar David Schulz Committed by hjk

Debugger: Fix gdb makefile for Ubuntu >= 11.10

Since Ubuntu 11.10 the linker option --as-needed is default,
which causes a build failure.
https://wiki.ubuntu.com/OneiricOcelot/ReleaseNotes#GCC_4.6_Toolchain

Fixed by passing "-Wl,--no-as-needed" to the linker.

Change-Id: Iea1db17d0930e4d4d08fa1e80ec594faa1ab2031
Reviewed-by: default avatarhjk <qthjk@ovi.com>
parent d45ae70d
......@@ -81,7 +81,7 @@ ${gdbtargets}: ${targetdir}/gdb-%: ${staging}/gdb-${version}/configure ${staging
test -e ${staging}/gdb-${version}-$* || mkdir ${staging}/gdb-${version}-$*
export PYTHONHOME=${staging} && \
export PATH="${staging}/bin/:$$PATH" && \
export LDFLAGS="-pthread -lm" && \
export LDFLAGS="-Wl,--no-as-needed -pthread -lm" && \
cd ${staging}/gdb-${version}-$* && \
${staging}/gdb-${version}/configure --disable-nls --target=$* --with-separate-debug-dir="" \
--disable-werror --with-python=${staging} --with-libexpat-prefix=${staging} && \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment