Commit 600ac11c authored by El Mehdi Fekari's avatar El Mehdi Fekari Committed by Mehdi Fekari
Browse files

Qnx: Fix build errors



Change-Id: Ia053e4e58ced79635f744feb02a2a855eae0c48b
Reviewed-by: Nicolas Arnaud-Cormos's avatarNicolas Arnaud-Cormos <nicolas@kdab.com>
parent 7714075a
......@@ -40,6 +40,8 @@
#include "blackberrydebugtokenrequestdialog.h"
#include "ui_blackberrykeyswidget.h"
#include "qnxconstants.h"
#include <QInputDialog>
#include <QFileDialog>
#include <QMessageBox>
......
......@@ -450,7 +450,7 @@ void BlackBerryNDKSettingsWidget::launchBlackBerryInstallerWizard(
void BlackBerryNDKSettingsWidget::updatePage()
{
updateNdkList();
updateConfigurationList();
populateDefaultConfigurationCombo();
}
......
......@@ -31,7 +31,7 @@
#include "blackberrysetupwidget.h"
#include "blackberryconfigurationmanager.h"
#include "blackberryconfiguration.h"
#include "blackberryapilevelconfiguration.h"
#include "blackberrysigningutils.h"
#include "blackberrydeviceconfigurationwizard.h"
#include "blackberryinstallwizard.h"
......@@ -157,8 +157,8 @@ void APILevelSetupItem::fix()
if (!found.testFlag(Any) || !found.testFlag(Valid)) {
installAPILevel();
} else if (!found.testFlag(Active)) {
foreach (BlackBerryConfiguration *config,
BlackBerryConfigurationManager::instance().configurations()) {
foreach (BlackBerryApiLevelConfiguration *config,
BlackBerryConfigurationManager::instance().apiLevels()) {
if (config->isValid() && !config->isActive()) {
config->activate();
break;
......@@ -178,8 +178,8 @@ APILevelSetupItem::FoundTypes APILevelSetupItem::resolvedFoundType()
// TODO: for now, all Trunk versions are understood as 10.2 compliant
BlackBerryVersionNumber version_10_2(QLatin1String("10.2.0.0"));
foreach (BlackBerryConfiguration *config,
BlackBerryConfigurationManager::instance().configurations()) {
foreach (BlackBerryApiLevelConfiguration *config,
BlackBerryConfigurationManager::instance().apiLevels()) {
found |= Any;
if (config->isValid()) {
found |= Valid;
......@@ -190,7 +190,8 @@ APILevelSetupItem::FoundTypes APILevelSetupItem::resolvedFoundType()
}
}
BlackBerryConfiguration *config = BlackBerryConfigurationManager::instance().defaultConfiguration();
BlackBerryApiLevelConfiguration *config =
BlackBerryConfigurationManager::instance().defaultApiLevel();
if (config && config->version() > version_10_2)
found |= V_10_2_AS_DEFAULT;
......@@ -210,7 +211,7 @@ void APILevelSetupItem::handleInstallationFinished()
{
// manually-added API Levels are automatically registered by BlackBerryInstallWizard
// auto-detected API Levels needs to reloaded explicitly
BlackBerryConfigurationManager::instance().loadAutoDetectedConfigurations();
BlackBerryConfigurationManager::instance().loadAutoDetectedApiLevels();
validate();
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment