Commit 6d90cabe authored by Jarek Kobus's avatar Jarek Kobus Committed by Jarek Kobus

Clear minimum Qt version and required features when needed

When the user chooses back button and select something
different than Symbian or Meego the above fields
should be cleared.

Task-number: QTCREATORBUG-5708
Change-Id: I2a8557cd1ab60dfc309c585399cd5b2210b44cc9
Reviewed-on: http://codereview.qt.nokia.com/2513Reviewed-by: default avatarQt Sanity Bot <qt_sanity_bot@ovi.com>
Reviewed-by: default avatarKai Koehne <kai.koehne@nokia.com>
parent e7be96f6
......@@ -96,6 +96,10 @@ bool QtQuickAppWizardDialog::validateCurrentPage()
QSet<QString> requiredFeatures;
requiredFeatures << Constants::QTQUICKCOMPONENTS_MEEGO_TARGETFEATURE_ID;
targetsPage()->setRequiredFeatures(requiredFeatures);
} else {
targetsPage()->setMinimumQtVersion(QtSupport::QtVersionNumber(4, 7, 0));
QSet<QString> requiredFeatures;
targetsPage()->setRequiredFeatures(requiredFeatures);
}
}
return AbstractMobileAppWizardDialog::validateCurrentPage();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment