Commit 7812390b authored by Eike Ziller's avatar Eike Ziller

Update requirements for building Qt Creator

Change-Id: I462c496a6998862d1f1d09fc323342429115b67b
Reviewed-by: default avatarChristian Kandeler <christian.kandeler@theqtcompany.com>
Reviewed-by: default avatarhjk <hjk@theqtcompany.com>
Reviewed-by: Orgad Shaneh's avatarOrgad Shaneh <orgads@gmail.com>
Reviewed-by: default avatarRalf Nolden <nolden@kde.org>
parent 070e6235
......@@ -10,19 +10,17 @@ Windows 7 or later
(K)Ubuntu Linux 14.04 (64-bit) or later
macOS 10.8 or later
Building the sources requires Qt 5.5.0 or later.
## Compiling Qt Creator
Prerequisites:
* Qt 5.5.0 or later
* Qt 5.6.0 or later
* On Windows:
* ActiveState Active Perl
* MinGW with g++ 4.7 or Visual Studio 2013 Update 2 or later
* MinGW with g++ 4.8 or Visual Studio 2015 or later
* jom
* On Mac OS X: latest Xcode
* On Linux: g++ 4.7 or later
* On Linux: g++ 4.8 or later
The installed toolchains have to match the one Qt was compiled with.
......
......@@ -12,7 +12,7 @@ QtcProduct {
property var pluginRecommends: []
property var pluginTestDepends: []
property string minimumQtVersion: "5.5.0"
property string minimumQtVersion: "5.6.0"
condition: QtcFunctions.versionIsAtLeast(Qt.core.version, minimumQtVersion)
targetName: QtcFunctions.qtLibraryName(qbs, name)
......
include(qtcreator.pri)
#version check qt
!minQtVersion(5, 5, 0) {
!minQtVersion(5, 6, 0) {
message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
error("Use at least Qt 5.5.0.")
error("Use at least Qt 5.6.0.")
}
include(doc/doc.pri)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment