Commit 83db17ba authored by Robert Loehning's avatar Robert Loehning
Browse files

Increased needed Qt version to 4.7

Reviewed-by: con
parent 35a09f2e
#version check qt
contains(QT_VERSION, ^4\.[0-5]\..*) {
contains(QT_VERSION, ^4\.[0-6]\..*) {
message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
error("Use at least Qt 4.6.")
error("Use at least Qt 4.7.")
}
include(qtcreator.pri)
......
......@@ -16,8 +16,8 @@ TRANSLATIONS = $$prependAll(LANGUAGES, $$PWD/qtcreator_,.ts)
MIME_TR_H = $$IDE_DATA_PATH/translations/mime_tr.h
contains(QT_VERSION, ^4\.[0-5]\..*) {
ts.commands = @echo This Qt version is too old for the ts target. Need Qt 4.6+.
contains(QT_VERSION, ^4\.[0-6]\..*) {
ts.commands = @echo This Qt version is too old for the ts target. Need Qt 4.7+.
} else {
for(dir, $$list($$files($$IDE_SOURCE_TREE/src/plugins/*))):MIMETYPES_FILES += $$files($$dir/*.mimetypes.xml)
MIMETYPES_FILES = \"$$join(MIMETYPES_FILES, \", \")\"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment