Commit 8993c557 authored by hjk's avatar hjk

Debugger: Add new test for OpenSUSE 13.1 GDB version string

"GNU gdb (GDB; openSUSE 13.1) 7.6.50.20130731-cvs", and failing.

Change-Id: I16c3af14127a7afb56454e56d7d92cb349b921d4
Reviewed-by: default avatarhjk <hjk121@nokiamail.com>
parent 192512e4
......@@ -60,7 +60,9 @@ void tst_gdb::version()
bool qnx = true;
Debugger::Internal::extractGdbVersion(msg, &v, &bv, &mac, &qnx);
//qDebug() << msg << " -> " << v << bv << mac << qnx;
QEXPECT_FAIL("openSUSE 13.1", "Not done yet", Continue);
QCOMPARE(v, gdbVersion);
QEXPECT_FAIL("openSUSE 13.1", "Not done yet", Continue);
QCOMPARE(bv, gdbBuildVersion);
QCOMPARE(mac, isMacGdb);
QCOMPARE(qnx, isQnxGdb);
......@@ -117,6 +119,10 @@ void tst_gdb::version_data()
QTest::newRow("rubenvb")
<< "GNU gdb (rubenvb-4.7.2-release) 7.5.50.20120920-cvs"
<< 70550 << 20120920 << false << false;
QTest::newRow("openSUSE 13.1")
<< "GNU gdb (GDB; openSUSE 13.1) 7.6.50.20130731-cvs"
<< 70650 << 20130731 << false << false;
}
static QString chopConst(QString type)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment