Commit 9ebe266a authored by Filipe Azevedo's avatar Filipe Azevedo

Add public api to set the inferior environment

This is needed for the GammaRay plugin.

Change-Id: Ia76c02756e9deb6f679c871a5cba1f6fc4c5028f
Reviewed-by: default avatarhjk <hjk@qt.io>
parent c054dd2c
......@@ -427,6 +427,11 @@ void DebuggerRunTool::setInferiorExecutable(const QString &executable)
m_runParameters.inferior.executable = executable;
}
void DebuggerRunTool::setInferiorEnvironment(const Utils::Environment &env)
{
m_runParameters.inferior.environment = env;
}
void DebuggerRunTool::setRunControlName(const QString &name)
{
m_runParameters.displayName = name;
......
......@@ -81,6 +81,7 @@ public:
void setInferior(const ProjectExplorer::Runnable &runnable);
void setInferiorExecutable(const QString &executable);
void setInferiorEnvironment(const Utils::Environment &env); // Used by GammaRay plugin
void setRunControlName(const QString &name);
void setStartMessage(const QString &msg);
void appendInferiorCommandLineArgument(const QString &arg);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment