Commit a0127da1 authored by Topi Reinio's avatar Topi Reinio Committed by Topi Reiniö

Doc: Clear a number of documentation warnings

QDoc gets confused about the contents of doc_src_plugins.qdoc,
mistaking some of its code for QDoc commands.

To work around this problem, change the file to be a qdoc
include file, wrap the code blocks with \badcode, and
refer to them using \include.

Using \badcode will also turn off code highlighting and
autolinking, something that is not desired for these code
snippets.

Change-Id: I6c3b65ef098ec6f6f06892d78a3abb38e0d28ca3
Reviewed-by: default avatarLeena Miettinen <riitta-leena.miettinen@digia.com>
parent 79c0a29d
......@@ -17,11 +17,14 @@
****************************************************************************/
//! [0]
\badcode
otool -L /Developer/Applications/Qt/plugins/designer/libqwt_designer_plugin.dylib
\endcode
//! [0]
//! [1]
\badcode
/Developer/Applications/Qt/plugins/designer/libqwt_designer_plugin.dylib:
libqwt_designer_plugin.dylib (compatibility version 0.0.0, current version 0.0.0)
libqwt.5.dylib (compatibility version 5.2.0, current version 5.2.1)
......@@ -33,14 +36,18 @@ otool -L /Developer/Applications/Qt/plugins/designer/libqwt_designer_plugin.dyli
/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.9.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 438.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.0.1)
\endcode
//! [1]
//! [2]
\badcode
otool -L /usr/local/qwt-5.2.1/lib/libqwt.5.dylib
\endcode
//! [2]
//! [3]
\badcode
/usr/local/qwt-5.2.1/lib/libqwt.5.dylib:
libqwt.5.dylib (compatibility version 5.2.0, current version 5.2.1)
QtGui.framework/Versions/4/QtGui (compatibility version 4.6.0, current version 4.6.2)
......@@ -48,18 +55,22 @@ otool -L /usr/local/qwt-5.2.1/lib/libqwt.5.dylib
/usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.9.0)
/usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 438.0.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 125.0.1)
\endcode
//! [3]
//! [4]
\badcode
sudo cp /Developer/Applications/Qt/plugins/designer/libqwt_designer_plugin.dylib \
/Developer/Applications/Qt/Qt\ Creator.app/Contents/MacOS/designer
sudo cp -R /usr/local/qwt-5.2.1/lib/* \
/Developer/Applications/Qt/Qt\ Creator.app/Contents/Frameworks/
\endcode
//! [4]
//! [5]
\badcode
cd /Developer/Applications/Qt/Qt\ Creator.app/Contents/MacOS/designer
sudo install_name_tool -change
QtCore.framework/Versions/4/QtCore \
......@@ -90,4 +101,6 @@ sudo install_name_tool -change \
QtGui.framework/Versions/4/QtGui \
@executable_path/../Frameworks/libQtGui.4.dylib \
libqwt.5.2.1.dylib
\endcode
//! [5]
......@@ -85,13 +85,13 @@
\li To check the paths used in the Qwt library, enter the following
\c otool command:
\snippet doc_src_plugins.qdoc 0
\include doc_src_plugins.qdocinc 0
The output for Qwt 5.2.1 indicates that the plugin uses Qt core
libraries (QtDesigner, QtScript, QtXml, QtGui and QtCore) and
libqwt.5.dylib:
\snippet doc_src_plugins.qdoc 1
\include doc_src_plugins.qdocinc 1
\li You must copy the \QD plugin and the Qwt library files to the
......@@ -108,21 +108,21 @@
Enter the following commands:
\snippet doc_src_plugins.qdoc 4
\include doc_src_plugins.qdocinc 4
\li Enter the following \c otool command to check the libraries that are
used by the Qwt library:
\snippet doc_src_plugins.qdoc 2
\include doc_src_plugins.qdocinc 2
The command returns the following output:
\snippet doc_src_plugins.qdoc 3
\include doc_src_plugins.qdocinc 3
\li Enter the following \c install_name_tool command to fix the
references of the libraries:
\snippet doc_src_plugins.qdoc 5
\include doc_src_plugins.qdocinc 5
\endlist
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment