Commit a0740f7e authored by hjk's avatar hjk

Debugger: Adjust "supported version" message to reality

Change-Id: I2288592d917089f9c952c96f77150db0b88b1fce
Reviewed-by: default avatarhjk <hjk121@nokiamail.com>
parent 499c3d35
......@@ -1704,11 +1704,10 @@ void GdbEngine::handleShowVersion(const GdbResponse &response)
extractGdbVersion(msg,
&m_gdbVersion, &gdbBuildVersion, &isMacGdb, &m_isQnxGdb);
// On Mac, fsf gdb does not work sufficiently well,
// and on Linux and Windows we require at least 7.2.
// Older versions with python still work, but can
// be significantly slower.
bool isSupported = m_gdbVersion >= 70500;
// On Mac, FSF GDB does not work sufficiently well,
// and on Linux and Windows we require at least 7.4.1,
// on Android 7.3.1.
bool isSupported = m_gdbVersion >= 70300;
if (isSupported)
showMessage(_("SUPPORTED GDB VERSION ") + msg);
else
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment