Commit a3a20c56 authored by Daniel Teske's avatar Daniel Teske

Android: Fix unnecessary warnings from qt about .arg

Change-Id: I780dcf3ebd174275389620319e2d4b4784c84346
Reviewed-by: default avatarDaniel Teske <daniel.teske@digia.com>
Reviewed-by: default avatarBogDan Vatra <bogdan@kde.org>
parent f7c68f6b
......@@ -914,7 +914,9 @@ QString AndroidManager::loadLocal(ProjectExplorer::Target *target, int apiLevel,
while (!libElement.isNull()) {
if (libElement.attribute(QLatin1String("bundling")).toInt() == (item == BundledJar ? 1 : 0)) {
if (libElement.hasAttribute(attribute)) {
QString dependencyLib = libElement.attribute(attribute).arg(apiLevel);
QString dependencyLib = libElement.attribute(attribute);
if (dependencyLib.contains(QLatin1String("%1")))
dependencyLib = dependencyLib.arg(apiLevel);
if (libElement.hasAttribute(QLatin1String("extends"))) {
const QString extends = libElement.attribute(QLatin1String("extends"));
if (libs.contains(extends)) {
......@@ -926,7 +928,9 @@ QString AndroidManager::loadLocal(ProjectExplorer::Target *target, int apiLevel,
}
if (libElement.hasAttribute(QLatin1String("replaces"))) {
QString replacedLib = libElement.attribute(QLatin1String("replaces")).arg(apiLevel);
QString replacedLib = libElement.attribute(QLatin1String("replaces"));
if (replacedLib.contains(QLatin1String("%1")))
replacedLib = replacedLib.arg(apiLevel);
if (!replacedLibs.contains(replacedLib))
replacedLibs << replacedLib;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment