Commit a6d12177 authored by Christian Kandeler's avatar Christian Kandeler

qbs build: Use require() instead of loadExtension()

This fixes a number of deprecation warnings. The require() function was
introduced in qbs 1.8 and is safe to use now.

Change-Id: I915a9f62f36fc64086c7dce60ea753d3e564127c
Reviewed-by: Jake Petroules's avatarJake Petroules <jake.petroules@qt.io>
Reviewed-by: Joerg Bornemann's avatarJoerg Bornemann <joerg.bornemann@qt.io>
parent 84b57027
var Environment = loadExtension("qbs.Environment")
var File = loadExtension("qbs.File")
var FileInfo = loadExtension("qbs.FileInfo")
var Environment = require("qbs.Environment")
var File = require("qbs.File")
var FileInfo = require("qbs.FileInfo")
var MinimumLLVMVersion = "3.9.0"
var Process = loadExtension("qbs.Process")
var Process = require("qbs.Process")
function readOutput(executable, args)
{
......
var File = loadExtension("qbs.File");
var FileInfo = loadExtension("qbs.FileInfo");
var TextFile = loadExtension("qbs.TextFile");
var File = require("qbs.File");
var FileInfo = require("qbs.FileInfo");
var TextFile = require("qbs.TextFile");
function getExportBlock(productFile)
{
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment