Commit a84ad427 authored by dt's avatar dt

Designer: Move dependency from CppEditor to CppTools

That makes CppEditor almost a leaf node in the project dependencies.
parent d6bff094
......@@ -16,6 +16,7 @@ Alternatively, this plugin may be used under the terms of the GNU Lesser General
<dependencyList>
<dependency name="Core" version="2.1.81"/>
<!-- For compiling with CPP support enabled -->
<dependency name="CppEditor" version="2.1.81"/>
<dependency name="CppTools" version="2.1.81"/>
<dependency name="TextEditor" version="2.1.81"/>
</dependencyList>
</plugin>
include(../../plugins/cppeditor/cppeditor.pri)
include(../../libs/cplusplus/cplusplus.pri)
include(../../plugins/cpptools/cpptools.pri)
include(../../plugins/texteditor/texteditor.pri)
include(../../libs/utils/utils.pri)
include(../../plugins/coreplugin/coreplugin.pri)
......@@ -34,7 +34,6 @@
#ifdef CPP_ENABLED
# include "formclasswizard.h"
# include <cppeditor/cppeditorconstants.h>
# include "cppsettingspage.h"
#endif
......
......@@ -87,7 +87,7 @@ plugin_imageviewer.subdir = imageviewer
plugin_imageviewer.depends = plugin_coreplugin
plugin_designer.subdir = designer
plugin_designer.depends = plugin_coreplugin plugin_cppeditor plugin_projectexplorer
plugin_designer.depends = plugin_coreplugin plugin_cpptools plugin_projectexplorer plugin_texteditor
plugin_vcsbase.subdir = vcsbase
plugin_vcsbase.depends = plugin_find
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment