Commit a9103d92 authored by Tobias Hunger's avatar Tobias Hunger

GCC: Autodetect old GCC versions needed for macx-g++XY mkspecs

Change-Id: If35b1ef2c0eba424cbdf70e0405243c14d413bab
Reviewed-by: default avatarDaniel Teske <daniel.teske@nokia.com>
parent adec0ae5
......@@ -582,7 +582,13 @@ QList<ToolChain *> Internal::GccToolChainFactory::autoDetect()
// Fixme Prefer lldb once it is implemented: debuggers.push_back(QLatin1String("lldb"));
#endif
debuggers.push_back(QLatin1String("gdb"));
return autoDetectToolchains(QLatin1String("g++"), debuggers, Abi::hostAbi());
QList<ToolChain *> tcs = autoDetectToolchains(QLatin1String("g++"), debuggers, Abi::hostAbi());
// Old mac compilers needed to support macx-gccXY mkspecs:
tcs.append(autoDetectToolchains(QLatin1String("g++-4.0"), debuggers, Abi::hostAbi()));
tcs.append(autoDetectToolchains(QLatin1String("g++-4.2"), debuggers, Abi::hostAbi()));
return tcs;
}
// Used by the ToolChainManager to restore user-generated tool chains
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment