Commit a93765c5 authored by BogDan Vatra's avatar BogDan Vatra Committed by Daniel Teske

Don't crash when can't detect the qt abi.

Change-Id: I103d5199d608a166e15098a89d63f4f7cc1f5c21
Reviewed-by: default avatarDaniel Teske <daniel.teske@digia.com>
parent 6afb941b
......@@ -588,7 +588,10 @@ void AndroidConfigurations::updateAutomaticKitList()
foreach (QtSupport::BaseQtVersion *qtVersion, QtSupport::QtVersionManager::instance()->versions()) {
if (qtVersion->type() != QLatin1String(Constants::ANDROIDQT))
continue;
qtVersionsForArch[qtVersion->qtAbis().first().architecture()].append(qtVersion);
QList<ProjectExplorer::Abi> qtAbis = qtVersion->qtAbis();
if (qtAbis.empty())
continue;
qtVersionsForArch[qtAbis.first().architecture()].append(qtVersion);
}
ProjectExplorer::DeviceManager *dm = ProjectExplorer::DeviceManager::instance();
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment