Commit ac2af19e authored by Kai Koehne's avatar Kai Koehne
Browse files

QMakeStep: Fix qmljsdebugger warning issues

Debugging requires 4.7.1 minimum. Also update the label if the
user switches Qt versions.

Reviewed-by: dt
parent 956435f9
......@@ -336,7 +336,7 @@ bool QMakeStep::isQmlDebuggingLibrarySupported(QString *reason) const
return false;
}
if (qt4BuildConfiguration()->qtVersion()->qtVersion() < QtVersionNumber(4, 7 ,0)) {
if (qt4BuildConfiguration()->qtVersion()->qtVersion() < QtVersionNumber(4, 7, 1)) {
if (reason)
*reason = tr("Requires Qt 4.7.1 or newer.");
return false;
......@@ -449,6 +449,7 @@ void QMakeStepConfigWidget::qtVersionChanged()
{
updateSummaryLabel();
updateEffectiveQMakeCall();
updateQmlDebuggingWarningsLabel();
}
void QMakeStepConfigWidget::qmakeBuildConfigChanged()
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment