Commit b467d0a9 authored by Daniel Teske's avatar Daniel Teske
Browse files

Don't check depth of source vs build dir for Qt >=4.8



The bug in qmake leading to the warning is fixed.

Change-Id: I032bb5ad502a9eb3e8f43abc86e9aa8c9e7942c4
Reviewed-by: default avatarDaniel Teske <daniel.teske@nokia.com>
parent 3cc1a2a9
......@@ -1008,7 +1008,7 @@ QList<ProjectExplorer::Task> BaseQtVersion::reportIssuesImpl(const QString &proF
"Qmake does not support build directories below the source directory.");
results.append(ProjectExplorer::Task(ProjectExplorer::Task::Warning, msg, QString(), -1,
QLatin1String(ProjectExplorer::Constants::TASK_CATEGORY_BUILDSYSTEM)));
} else if (tmpBuildDir.count(QChar('/')) != sourcePath.count(QChar('/'))) {
} else if (tmpBuildDir.count(QChar('/')) != sourcePath.count(QChar('/')) && qtVersion() < QtVersionNumber(4,8, 0)) {
const QString msg = QCoreApplication::translate("Qt4ProjectManager::QtVersion",
"The build directory needs to be at the same level as the source directory.");
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment