Commit b5e79e35 authored by Tobias Hunger's avatar Tobias Hunger
Browse files

Report failures to find ABIs of Qt versions

Give a reason why the Qt version is not valid when we were not
able to detect the ABIs used by the Qt version.
parent aa5b5e23
......@@ -1768,6 +1768,8 @@ QString QtVersion::invalidReason() const
"Could not determine the path to the binaries of the Qt installation, maybe the qmake path is wrong?");
if (m_abiUpToDate && m_mkspecFullPath.isEmpty())
return QCoreApplication::translate("QtVersion", "The default mkspec symlink is broken.");
if (m_abiUpToDate && m_abis.isEmpty())
return QCoreApplication::translate("QtVersion", "Failed to detect the ABI(s) used by the Qt version.");
return QString();
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment