Commit c234c7cf authored by hjk's avatar hjk
Browse files

debugger: don't show the version nag dialog if version extraction went wrong

parent e565fb61
......@@ -751,7 +751,12 @@ void GdbEngine::handleDebuggingHelperVersionCheckClassic(const GdbResponse &resp
QString value = _(response.data.findChild("value").data());
QString debuggeeQtVersion = value.section(QLatin1Char('"'), 1, 1);
QString dumperQtVersion = m_dumperHelper.qtVersionString();
if (dumperQtVersion != debuggeeQtVersion) {
if (debuggeeQtVersion.isEmpty()) {
showMessage(_("DUMPER VERSION CHECK SKIPPED, NO qVersion() OUTPUT IN")
+ response.toString());
} else if (dumperQtVersion.isEmpty()) {
showMessage(_("DUMPER VERSION CHECK SKIPPED, NO VERSION STRING"));
} else if (dumperQtVersion != debuggeeQtVersion) {
showMessageBox(QMessageBox::Warning,
tr("Debugging helpers: Qt version mismatch"),
tr("The Qt version used to build the debugging helpers (%1) "
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment