Commit c89ffbe3 authored by Eike Ziller's avatar Eike Ziller
Browse files

Installer: Suppress error if newer version of vcredist is already installed



Task-number: QTCREATORBUG-8076

Change-Id: Ia39491569fe696ec27c8375251ce6a0d5923dc1e
Reviewed-by: default avatarKarsten Heimrich <karsten.heimrich@digia.com>
Reviewed-by: default avatarTim Jenssen <tim.jenssen@digia.com>
parent 2f3730ca
......@@ -121,7 +121,7 @@ Component.prototype.createOperations = function()
"@TargetDir@\\bin\\qtcreator.exe",
"@StartMenuDir@/Qt Creator.lnk",
"workingDirectory=@homeDir@" );
component.addElevatedOperation("Execute", "{0,3010}", "@TargetDir@\\lib\\vcredist_msvc2010\\vcredist_x86.exe", "/norestart", "/q");
component.addElevatedOperation("Execute", "{0,3010,1638}", "@TargetDir@\\lib\\vcredist_msvc2010\\vcredist_x86.exe", "/norestart", "/q");
registerWindowsFileTypeExtensions();
}
if ( installer.value("os") == "x11" )
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment