Commit d6dee160 authored by Kai Koehne's avatar Kai Koehne
Browse files

Plugins: Update Qt version checks



Remove the warning for Qt 4.7.0: The minimum version for Qt Creator is now Qt 4.7.4.

Instead, warn users that the QmlX plugins won't be compiled if QtDeclarative or QtQuick1 is missing.
(QtQuick1 isn't compiled by default on Qt 5).

Change-Id: Ib9713282ad3759045a6eb994da1a12aac5176910
Reviewed-by: default avatarThomas Hartmann <Thomas.Hartmann@nokia.com>
parent 8ceff27c
......@@ -67,20 +67,14 @@ contains(QT_CONFIG, declarative)|contains(QT_CONFIG, quick1) {
include(../private_headers.pri)
exists($${QT_PRIVATE_HEADERS}/QtDeclarative/private/qdeclarativecontext_p.h) {
minQtVersion(4, 7, 1) {
SUBDIRS += plugin_qmldesigner
} else {
warning()
warning("QmlDesigner plugin has been disabled.")
warning("QmlDesigner requires Qt 4.7.1 or later.")
}
} else {
warning()
warning("QmlDesigner plugin has been disabled.")
warning("The plugin depends on private headers from QtDeclarative module.")
warning("To enable it, pass 'QT_PRIVATE_HEADERS=$QTDIR/include' to qmake, where $QTDIR is the source directory of qt.")
}
} else {
warning("QmlProjectManager, QmlProfiler and QmlDesigner plugins have been disabled: The plugins require QtDeclarative (Qt 4.x) or QtQuick1 (Qt 5.x)");
}
include (debugger/lldb/guest/qtcreator-lldb.pri)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment