Commit d744919b authored by Daniel Teske's avatar Daniel Teske
Browse files

Android: Device selection dialog, fix error messages



Change-Id: Ie9d1535ae93ca0a28bf7f6ccd3ee73bcb783be4c
Reviewed-by: default avatarDaniel Teske <daniel.teske@digia.com>
parent 8f7bbb9a
......@@ -339,12 +339,10 @@ void AndroidDeviceModel::setDevices(const QVector<AndroidDeviceInfo> &devices)
if (device.unauthorized) {
error = tr("Unauthorized. Please check the confirmation dialog on your device..").arg(device.serialNumber);
} else if (!device.cpuAbi.contains(m_abi)) {
error = tr("ABI is incompatible, device supports ABIs: %2.")
.arg(AndroidConfigurations::instance().getProductModel(device.serialNumber))
error = tr("ABI is incompatible, device supports ABIs: %1.")
.arg(device.cpuAbi.join(QLatin1String(" ")));
} else if (device.sdk < m_apiLevel) {
error = tr("API Level of device is: %2.")
.arg(AndroidConfigurations::instance().getProductModel(device.serialNumber))
error = tr("API Level of device is: %1.")
.arg(device.sdk);
} else {
new AndroidDeviceModelNode(compatibleDevices, device);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment