Commit dfaec063 authored by Eike Ziller's avatar Eike Ziller

Update minimum required Qt version.

We require Qt 5.2 for full functionality nowadays.
It is possible to use Qt 4.8.x with restrictions.
(Qt 5.0 and 5.1 do not work because of problems with embedding
Qt Quick 2 and other Qt Quick related issues (e.g. QTCREATORBUG-10273)

Change-Id: Ib41576e8b8e3727e87141eaf0351d63158730524
Reviewed-by: default avatarLeena Miettinen <riitta-leena.miettinen@digia.com>
parent 9fbf0ac1
......@@ -10,12 +10,14 @@ Windows XP SP2 or later
(K)Ubuntu Linux 11.10 (32-bit and 64-bit) or later
Mac OS 10.6 or later
Building the sources requires Qt 4.8.0 or later.
Building the sources requires Qt 5.2.0 or later.
It is also possible to build with Qt 4.8.x, but in that case the Welcome mode,
Qt Quick Designer and QML Profiler are disabled.
Compiling Qt Creator
====================
Prerequisites:
* Qt 4.8.0 or later
* Qt 5.2.0 or later (with restrictions also Qt 4.8.x)
* On Windows:
- ActiveState Active Perl
- MinGW or Visual Studio
......
......@@ -68,7 +68,7 @@ isEmpty(IDE_PACKAGE_MODE) {
updateinfo
}
minQtVersion(5, 1, 0) {
minQtVersion(5, 2, 0) {
SUBDIRS += \
qmldesigner \
qmlprofiler \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment