Commit e12d360c authored by Christian Kamm's avatar Christian Kamm

QmlJS: Require Qt >= 4.8.0 to dump builtins.

The qmlplugindump tool is only shipped with Qt since 4.8.0.

Change-Id: I05c77da2bcfc9e1dbf055c45add78543cacce79c
Reviewed-by: default avatarNiels Weber <niels.2.weber@nokia.com>
Reviewed-by: default avatarTim Jenssen <tim.jenssen@nokia.com>
Reviewed-by: default avatarEike Ziller <eike.ziller@nokia.com>
parent 6c049b89
......@@ -349,8 +349,9 @@ void ModelManager::updateProjectInfo(const ProjectInfo &pinfo)
}
updateSourceFiles(newFiles, false);
// dump builtin types if the shipped definitions are probably outdated
if (QtSupport::QtVersionNumber(pinfo.qtVersionString) > QtSupport::QtVersionNumber(4, 7, 3))
// dump builtin types if the shipped definitions are probably outdated and the
// Qt version ships qmlplugindump
if (QtSupport::QtVersionNumber(pinfo.qtVersionString) >= QtSupport::QtVersionNumber(4, 8, 0))
m_pluginDumper->loadBuiltinTypes(pinfo);
emit projectInfoUpdated(pinfo);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment