Commit f03a76e1 authored by Friedemann Kleint's avatar Friedemann Kleint Committed by Oswald Buddenhagen
Browse files

Fix qmake-warnings in Qt 5.



Use QT += help, designer, clean up Designer include hack.

Change-Id: I630cc7575d541ba4dc6c5cbecd335dbb8167e1c9
Reviewed-by: default avatarOswald Buddenhagen <oswald.buddenhagen@nokia.com>
parent ec6f0db8
...@@ -9,11 +9,8 @@ include(designer_dependencies.pri) ...@@ -9,11 +9,8 @@ include(designer_dependencies.pri)
INCLUDEPATH += ../../tools/utils INCLUDEPATH += ../../tools/utils
minQtVersion(5, 0, 0) { greaterThan(QT_MAJOR_VERSION, 4) {
CONFIG += designer QT += printsupport designer
# -- Fixme: Make tools available
INCLUDEPATH += $$QMAKE_INCDIR_QT/../../qttools/include
QT += printsupport
} else { } else {
# -- figure out shared dir location # -- figure out shared dir location
!exists($$[QT_INSTALL_HEADERS]/QtDesigner/private/qdesigner_integration_p.h) { !exists($$[QT_INSTALL_HEADERS]/QtDesigner/private/qdesigner_integration_p.h) {
......
...@@ -3,8 +3,10 @@ TARGET = Help ...@@ -3,8 +3,10 @@ TARGET = Help
QT += network QT += network
greaterThan(QT_MAJOR_VERSION, 4) { greaterThan(QT_MAJOR_VERSION, 4) {
QT += printsupport QT += printsupport help
DEFINES += QT_NO_WEBKIT DEFINES += QT_NO_WEBKIT
} else {
CONFIG += help
} }
INCLUDEPATH += $$PWD INCLUDEPATH += $$PWD
...@@ -12,7 +14,6 @@ INCLUDEPATH += $$PWD ...@@ -12,7 +14,6 @@ INCLUDEPATH += $$PWD
include(../../qtcreatorplugin.pri) include(../../qtcreatorplugin.pri)
include(help_dependencies.pri) include(help_dependencies.pri)
CONFIG += help
DEFINES += QT_CLUCENE_SUPPORT HELP_LIBRARY DEFINES += QT_CLUCENE_SUPPORT HELP_LIBRARY
HEADERS += \ HEADERS += \
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment