Commit fb89bfe9 authored by Thiago Macieira's avatar Thiago Macieira Committed by Friedemann Kleint

Request Qt pre-5.0 API for Qt 5 builds

Qt Creator currently must compile with both Qt 4 and Qt 5, so we can't
change the code to call the non-deprecated functions that have been
recently deprecated in Qt 5, unless those functions already existed.

This change asks Qt 5 to enable the use of pre-5.0 API without warnings.

Change-Id: Ic165336f40d15fe5793d30bb9262986f738c984e
Reviewed-by: default avatarEike Ziller <eike.ziller@nokia.com>
Reviewed-by: default avatarFriedemann Kleint <Friedemann.Kleint@nokia.com>
parent 8113465f
......@@ -157,4 +157,5 @@ win32-msvc* {
qt:greaterThan(QT_MAJOR_VERSION, 4) {
contains(QT, core): QT += concurrent
contains(QT, gui): QT += widgets
DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x040900
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment