1. 12 Jun, 2017 1 commit
  2. 05 Jan, 2017 1 commit
    • Marco Bubke's avatar
      Bump C++ version to 14 · ddbe6117
      Marco Bubke authored
      Our compilers support some features which are part of the C++ 14 feature
      set. Some off them are silently compiled with the C++ 11 setting.
      
      For example:
      
      [foo=bar] {}
      
      is actually working with GCC but is part of C++ 14.
      
      Change-Id: Icf2c3806e26c675f8251768c6ad54ba4da186d11
      Reviewed-by: Eike Ziller's avatarEike Ziller <eike.ziller@qt.io>
      ddbe6117
  3. 01 Aug, 2016 1 commit
  4. 23 Jun, 2016 1 commit
  5. 15 Jun, 2016 1 commit
    • Christian Kandeler's avatar
      qbs build: Final steps to support building plugins "out of source". · e1e20359
      Christian Kandeler authored
      - Use the entire Export block when creating a module, not just the
        Depends items. Adapt references to the product source directory
        and the "share" directory so that they point to the respective
        locations in the install tree.
      - Install dev headers for some more plugins.
      - Bug fixes & polishing.
      
      Create a "dev installation" like this:
      $ qbs qtc.make_dev_package:true qbs.installRoot:<install root>
      
      Then build your plugin against it like this:
      $ qbs qtc.make_dev_package:true qbs.installRoot:<install root>
      project.qbsSearchPaths:<install root>/qbs-resources
      (Using qbs from 1.5 branch; 1.5.1 requires a trivial wrapper project.)
      
      That's all. Successfully tested with all commercial plugins on Linux.
      
      Change-Id: Ie39c4717dafcd431c533421a15f2f898783d8521
      Reviewed-by: Jake Petroules's avatarJake Petroules <jake.petroules@qt.io>
      Reviewed-by: Orgad Shaneh's avatarOrgad Shaneh <orgads@gmail.com>
      e1e20359
  6. 13 Jun, 2016 1 commit
  7. 08 Jun, 2016 1 commit
  8. 17 May, 2016 1 commit
  9. 13 May, 2016 1 commit
    • Christian Kandeler's avatar
      Set the right version number on our binaries. · 87e8f03c
      Christian Kandeler authored
      While we have not encountered issues so far with using the default
      values, it seems more correct to set the version so that e.g. on Unix
      a library's soname contains the actual Qt Creator major version etc.
      For good measure, also set the compatibility version on OS X.
      
      Change-Id: I956c473e0b440fc87ffe1aaf99af626da733b5fb
      Reviewed-by: Eike Ziller's avatarEike Ziller <eike.ziller@qt.io>
      87e8f03c
  10. 07 Dec, 2015 1 commit
  11. 21 Oct, 2015 1 commit
  12. 20 Jan, 2015 1 commit
  13. 23 Jul, 2014 1 commit
  14. 21 May, 2014 1 commit
  15. 07 May, 2014 1 commit
  16. 22 Apr, 2014 1 commit
  17. 08 Apr, 2014 1 commit
  18. 14 Mar, 2014 1 commit
  19. 11 Mar, 2014 1 commit
  20. 11 Oct, 2013 1 commit
  21. 09 Oct, 2013 1 commit
  22. 07 Oct, 2013 1 commit
  23. 09 Sep, 2013 1 commit
  24. 12 Jul, 2013 1 commit
  25. 11 Jun, 2013 1 commit
  26. 22 Apr, 2013 1 commit
  27. 24 Jan, 2013 1 commit
  28. 17 Sep, 2012 1 commit
  29. 13 Sep, 2012 1 commit
  30. 14 Aug, 2012 1 commit
  31. 21 May, 2012 1 commit