1. 08 Nov, 2011 1 commit
  2. 03 Nov, 2011 1 commit
  3. 31 Oct, 2011 1 commit
  4. 24 Oct, 2011 1 commit
  5. 29 Sep, 2011 1 commit
  6. 26 Sep, 2011 1 commit
  7. 23 Sep, 2011 1 commit
  8. 15 Sep, 2011 1 commit
  9. 08 Sep, 2011 1 commit
    • Tobias Hunger's avatar
      ABI: Improve tool chain selection for Qt projects · aaf260c0
      Tobias Hunger authored
      * Set a null-ABI for toolchains where detection of ABI failed: This
        allows the user to select any tool chain.
      
      * Warn if ABI detection fails by showing a message in the Qt version
        setup dialog
      
      * Do not override the mkspec if the Qt version has a null ABI only:
        We (have to) trust the user to know what he is doing in that case.
      
      * GCC: Add version information to GCC tool chain and use it to select
        the mkspec on Mac.
      
      * GCC: Do not override mkspec if we do a cross-compile
        (and actually detect that).
      
      * GCC: Leave out -32 or -64 from mkspec if the compiler binaries ABI
        matches the target ABI.
      
      * Linux-generic is compatible with all other linuxes (both ways)
        The targets themselves do additional filtering and will remove
        anything that does not work for them anyway.
      
      Task-number: QTCREATORBUG-5756
      Task-number: QTCREATORBUG-5960
      Change-Id: Ib3c0ac91f3aa8e2a823e3e9891a02bdccb97af14
      Reviewed-on: http://codereview.qt-project.org/4281
      
      Reviewed-by: default avatarQt Sanity Bot <qt_sanity_bot@ovi.com>
      Reviewed-by: default avatarDaniel Teske <daniel.teske@nokia.com>
      aaf260c0
  10. 06 Sep, 2011 1 commit
  11. 25 Aug, 2011 1 commit
  12. 18 Aug, 2011 1 commit
  13. 17 Aug, 2011 1 commit
  14. 29 Jul, 2011 1 commit
  15. 20 Jul, 2011 1 commit
  16. 24 May, 2011 1 commit
  17. 20 May, 2011 1 commit
  18. 17 May, 2011 1 commit
  19. 13 May, 2011 2 commits
  20. 12 May, 2011 3 commits
    • Thorbjørn Lindeijer's avatar
      Disable observer and jsdebugger services when they're already part of Qt · 2b0266d0
      Thorbjørn Lindeijer authored
      As of Qt 4.8 the observer and jsdebugger services are part of Qt. This
      means the following changes are necessary in Qt Creator:
      
      * Do not link to the QmlJSDebugger library.
      * Do not create JSDebuggerAgent and QDeclarativeViewObserver instances
        in the QmlApplicationViewer and use the new declarative_debug CONFIG
        option to enable those services in Qt. This is done automatically
        for debug builds.
      * Point out the QML Debugging Library and the QML Observer are "Not
        needed" in the Qt options page.
      * Change the label in qmake options from "Link QML debugging library" to
        "Enable QML debugging". It still remains as a way to enable this
        functionality in release builds or for QtQuick applications not based
        on Qt Creator's template.
      * Rely on qmlviewer for debugging QML UI projects rather than the
        observer, which is no longer necessary.
      
      Reviewed-by: Kai Koehne
      2b0266d0
    • dt's avatar
      Fix whitespace/coding style · b4d38705
      dt authored
      b4d38705
    • dt's avatar
      Qt Version refactoring · 8e171e0b
      dt authored
      Split up target specific code into subclasses. Also change
      Qt4BuildConfiguration to allow a null qtversion.
      
      Remove code that relied on always having a qt version.
      Also make it possible to remove all qt versions.
      
      Completly change the qt in path autodetection to be only
      a fall back if no configuration was found.
      
      Note: For now the old settings are not removed, as such 2.2 and master
      can coexist.
      
      Reviewed-By: hunger
      8e171e0b