Commit 9650adad authored by Nikolai Kosjar's avatar Nikolai Kosjar

Clang: Require at least LLVM 3.8.0

Change-Id: I2de3eef7bc06cba6298d64a9a042a01decc05384
Reviewed-by: Eike Ziller's avatarEike Ziller <eike.ziller@qt.io>
parent bdff47af
......@@ -23,6 +23,7 @@ Prerequisites:
* jom
* On Mac OS X: latest Xcode
* On Linux: g++ 4.7 or later
* LLVM 3.8.0 or later for the Clang Code Model
The installed toolchains have to match the one Qt was compiled with.
......@@ -116,7 +117,7 @@ For detailed information on the supported compilers, see
command...` error. If a `sh.exe` is found, the compile process will fail.
You have to remove it from the path.
10. To enable the Clang-based code model: Install Clang (>= version 3.6.2)
10. To enable the Clang-based code model: Install Clang (>= version 3.8.0)
and set the environment variable LLVM_INSTALL_DIR to point to the
installation location.
......
......@@ -103,7 +103,7 @@
\list 1
\li Acquire Clang 3.6.2 or higher in one of the following ways:
\li Acquire Clang 3.8.0 or higher in one of the following ways:
\list
......
var Environment = loadExtension("qbs.Environment")
var File = loadExtension("qbs.File")
var MinimumLLVMVersion = "3.6.2"
var MinimumLLVMVersion = "3.8.0"
var Process = loadExtension("qbs.Process")
function readOutput(executable, args)
......@@ -27,8 +27,7 @@ function llvmConfig(qbs, qtcFunctions)
{
var llvmInstallDirFromEnv = Environment.getEnv("LLVM_INSTALL_DIR")
var llvmConfigVariants = [
"llvm-config", "llvm-config-3.2", "llvm-config-3.3", "llvm-config-3.4",
"llvm-config-3.5", "llvm-config-3.6", "llvm-config-4.0", "llvm-config-4.1"
"llvm-config", "llvm-config-3.8", "llvm-config-3.9", "llvm-config-4.0", "llvm-config-4.1"
];
// Prefer llvm-config* from LLVM_INSTALL_DIR
......
......@@ -106,6 +106,6 @@ unix {
}
isEmpty(LLVM_VERSION): error("Cannot determine clang version at $$LLVM_INSTALL_DIR")
!versionIsAtLeast($$LLVM_VERSION, 3, 6, 2): {
error("LLVM/Clang version >= 3.6.2 required, version provided: $$LLVM_VERSION")
!versionIsAtLeast($$LLVM_VERSION, 3, 8, 0): {
error("LLVM/Clang version >= 3.8.0 required, version provided: $$LLVM_VERSION")
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment