Commit dfd28a1d authored by Erik Verbruggen's avatar Erik Verbruggen

Fix build breakage after making plugins dependent on cpptools.

Change-Id: Iae2c15efe25580fb616bdc3dd4b8ff3581cd481a
Reviewed-by: default avatarEike Ziller <eike.ziller@nokia.com>
parent e5e3f91e
......@@ -122,8 +122,6 @@ DynamicLibrary {
"Macro.h",
"MatchingText.cpp",
"MatchingText.h",
"ModelManagerInterface.cpp",
"ModelManagerInterface.h",
"NamePrettyPrinter.cpp",
"NamePrettyPrinter.h",
"Overview.cpp",
......@@ -142,8 +140,6 @@ DynamicLibrary {
"SnapshotSymbolVisitor.h",
"SymbolNameVisitor.cpp",
"SymbolNameVisitor.h",
"TypeHierarchyBuilder.cpp",
"TypeHierarchyBuilder.h",
"TypeOfExpression.cpp",
"TypeOfExpression.h",
"TypePrettyPrinter.cpp",
......
......@@ -17,5 +17,6 @@ Alternatively, this plugin may be used under the terms of the GNU Lesser General
<dependency name=\"Core\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"ProjectExplorer\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"RemoteLinux\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"CppTools\" version=\"$$QTCREATOR_VERSION\"/>
</dependencyList>
</plugin>
......@@ -7,7 +7,7 @@ QtcPlugin {
Depends { name: "qt"; submodules: ['gui'] }
Depends { name: "Core" }
Depends { name: "CPlusPlus" }
Depends { name: "CppTools" }
Depends { name: "RemoteLinux" }
Depends { name: "ProjectExplorer" }
Depends { name: "TextEditor" }
......
......@@ -2,3 +2,4 @@ include(../../plugins/coreplugin/coreplugin.pri)
include(../../libs/cplusplus/cplusplus.pri)
include(../../plugins/projectexplorer/projectexplorer.pri)
include(../../plugins/remotelinux/remotelinux.pri)
include(../../plugins/cpptools/cpptools.pri)
......@@ -100,7 +100,11 @@ QtcPlugin {
"uicodecompletionsupport.h",
"cppcompletionassistprovider.cpp",
"cppcompletionassistprovider.h",
"cppcodestylepreferencesfactory.h"
"cppcodestylepreferencesfactory.h",
"ModelManagerInterface.cpp",
"ModelManagerInterface.h",
"TypeHierarchyBuilder.cpp",
"TypeHierarchyBuilder.h"
]
}
......@@ -17,6 +17,7 @@ Alternatively, this plugin may be used under the terms of the GNU Lesser General
<dependency name=\"ProjectExplorer\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"Core\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"Find\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"CppTools\" version=\"$$QTCREATOR_VERSION\"/>
<!-- Debugger plugin adds items to the editor\'s context menu -->
<dependency name=\"CppEditor\" version=\"$$QTCREATOR_VERSION\" type=\"optional\"/>
</dependencyList>
......
......@@ -120,6 +120,7 @@ plugin_vcsbase.depends = plugin_find
plugin_vcsbase.depends += plugin_texteditor
plugin_vcsbase.depends += plugin_coreplugin
plugin_vcsbase.depends += plugin_projectexplorer
plugin_vcsbase.depends += plugin_cpptools
plugin_perforce.subdir = perforce
plugin_perforce.depends = plugin_vcsbase
......@@ -253,6 +254,7 @@ plugin_qmldesigner.depends += plugin_qmljseditor
plugin_qmldesigner.depends += plugin_projectexplorer
plugin_qmldesigner.depends += plugin_qt4projectmanager
plugin_qmldesigner.depends += plugin_qmlprojectmanager
plugin_qmldesigner.depends += plugin_cpptools
plugin_qmljsinspector.subdir = qmljsinspector
plugin_qmljsinspector.depends += plugin_projectexplorer
......@@ -283,6 +285,7 @@ plugin_analyzerbase.subdir = analyzerbase
plugin_analyzerbase.depends = plugin_coreplugin
plugin_analyzerbase.depends += plugin_projectexplorer
plugin_analyzerbase.depends += plugin_remotelinux
plugin_analyzerbase.depends += plugin_cpptools
plugin_valgrind.subdir = valgrind
plugin_valgrind.depends = plugin_coreplugin
......@@ -300,6 +303,7 @@ plugin_qmljstools.depends = plugin_projectexplorer
plugin_qmljstools.depends += plugin_coreplugin
plugin_qmljstools.depends += plugin_texteditor
plugin_qmljstools.depends += plugin_qtsupport
plugin_qmljstools.depends += plugin_cpptools
plugin_macros.subdir = macros
plugin_macros.depends = plugin_texteditor
......
......@@ -8,7 +8,7 @@ QtcPlugin {
Depends { name: "qt"; submodules: ['gui'] }
Depends { name: "Core" }
Depends { name: "LanguageUtils" }
Depends { name: "CPlusPlus" }
Depends { name: "CppTools" }
Depends { name: "QmlJS" }
Depends { name: "ProjectExplorer" }
Depends { name: "TextEditor" }
......
......@@ -16,5 +16,6 @@ Alternatively, this plugin may be used under the terms of the GNU Lesser General
<dependency name=\"Core\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"ProjectExplorer\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"TextEditor\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"CppTools\" version=\"$$QTCREATOR_VERSION\"/>
</dependencyList>
</plugin>
......@@ -17,5 +17,6 @@ Alternatively, this plugin may be used under the terms of the GNU Lesser General
<dependency name=\"Core\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"TextEditor\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"ProjectExplorer\" version=\"$$QTCREATOR_VERSION\"/>
<dependency name=\"CppTools\" version=\"$$QTCREATOR_VERSION\"/>
</dependencyList>
</plugin>
......@@ -11,7 +11,7 @@ QtcPlugin {
Depends { name: "Find" }
Depends { name: "cpp" }
Depends { name: "qt"; submodules: ['gui'] }
Depends { name: "CPlusPlus" }
Depends { name: "CppTools" }
cpp.includePaths: [
".",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment