Commit 9103c221 authored by Johan Helsing's avatar Johan Helsing

Skip all versions < 5.11

parent aced00dc
const versionStringRe = /v?(\d+)\.(\d+)(\.(\d+))?/;
function parseVersion(versionString) {
const match = versionString.match(versionStringRe);
const major = parseInt(match[1]);
const minor = parseInt(match[2]);
const patch = parseInt(match[4]) || undefined;
return { major: major, minor: minor, patch: patch};
}
module.exports = parseVersion;
//console.log(parseVersion("5.10.1"));
//console.log(parseVersion("v5.10.1"));
//console.log(parseVersion("5.10"));
......@@ -10,6 +10,7 @@ const { scheduleJob } = require('node-schedule');
const gerritHost = 'codereview.qt-project.org';
const gerritSshPort = 29418;
const readLastLines = require('read-last-lines');
const parseVersion = require('./parseVersion');
const tests = [];
......@@ -91,7 +92,13 @@ function listenForGerritChanges() {
const { change, patchSet } = data;
const { project, subject, branch, url } = change;
if (project !== 'qt/qtwayland' || branch === '5.9') {
if (project !== 'qt/qtwayland') {
return;
}
const version = parseVersion(branch);
// The tests are currently broken for branches prior to 5.11
if (version.major === 5 && version.minor < 11) {
return;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment