From 0dded51636b689237af7fdcda1719790c7fb3aa7 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@digia.com>
Date: Tue, 23 Sep 2014 12:34:23 +0300
Subject: [PATCH] Move meta-ti specific files to separate layer

Create new layer for recipes and files that required only when
meta-ti layer is used. For now, the bblayers.conf template still
includes the new layer as well.

Change-Id: Iab8f6b3a61578e7a9579066ae7facca5a9a1f33b
Reviewed-by: Eirik Aavitsland <eirik.aavitsland@digia.com>
---
 conf/bblayers.conf.sample                     |  1 +
 meta-ti-extras/conf/layer.conf                | 33 +++++++++++++++++++
 .../recipes}/libgles/libgles-omap3/rc.pvr     |  0
 .../libgles/libgles-omap3_4.09.00.01.bbappend |  0
 .../libgles/libgles-omap3_4.10.00.01.bb       |  0
 .../libgles/libgles-omap3_5.01.01.01.bbappend |  0
 .../linux/linux-am335x-psp_3.2.bbappend       |  0
 .../linux/linux-mainline_3.2.bbappend         |  0
 .../linux/linux-ti-staging/usb-serial.cfg     |  0
 .../linux/linux-ti-staging_3.12.bbappend      |  0
 ...DK-04.10.00.01-AM335x-sgx-irq-change.patch |  0
 ...nge-for-interfacing-with-SGX-DT-node.patch |  0
 .../omap3-sgx-modules/linux-3.8.patch         |  0
 .../omap3-sgx-modules_4.10.00.01.bb           |  0
 ...-evm-disable-console-cursor-blinking.patch |  0
 .../u-boot/u-boot-am33x_2013.01.01.bbappend   |  0
 ...-BBB-disable-console-cursor-blinking.patch |  0
 .../u-boot/u-boot-ti-staging_2013.10.bbappend |  0
 18 files changed, 34 insertions(+)
 create mode 100644 meta-ti-extras/conf/layer.conf
 rename {recipes => meta-ti-extras/recipes}/libgles/libgles-omap3/rc.pvr (100%)
 rename {recipes => meta-ti-extras/recipes}/libgles/libgles-omap3_4.09.00.01.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/libgles/libgles-omap3_4.10.00.01.bb (100%)
 rename {recipes => meta-ti-extras/recipes}/libgles/libgles-omap3_5.01.01.01.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/linux/linux-am335x-psp_3.2.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/linux/linux-mainline_3.2.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/linux/linux-ti-staging/usb-serial.cfg (100%)
 rename {recipes => meta-ti-extras/recipes}/linux/linux-ti-staging_3.12.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch (100%)
 rename {recipes => meta-ti-extras/recipes}/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch (100%)
 rename {recipes => meta-ti-extras/recipes}/powervr-drivers/omap3-sgx-modules/linux-3.8.patch (100%)
 rename {recipes => meta-ti-extras/recipes}/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb (100%)
 rename {recipes => meta-ti-extras/recipes}/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch (100%)
 rename {recipes => meta-ti-extras/recipes}/u-boot/u-boot-am33x_2013.01.01.bbappend (100%)
 rename {recipes => meta-ti-extras/recipes}/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch (100%)
 rename {recipes => meta-ti-extras/recipes}/u-boot/u-boot-ti-staging_2013.10.bbappend (100%)

diff --git a/conf/bblayers.conf.sample b/conf/bblayers.conf.sample
index 777d0778..cade58ef 100644
--- a/conf/bblayers.conf.sample
+++ b/conf/bblayers.conf.sample
@@ -38,6 +38,7 @@ BBLAYERS ?= " \
   ##COREBASE##/meta-toradex \
   ##COREBASE##/meta-openembedded/meta-oe \
   ##COREBASE##/meta-b2qt \
+  ##COREBASE##/meta-b2qt/meta-ti-extras \
   "
 BBLAYERS_NON_REMOVABLE ?= " \
   ##COREBASE##/meta \
diff --git a/meta-ti-extras/conf/layer.conf b/meta-ti-extras/conf/layer.conf
new file mode 100644
index 00000000..120b5073
--- /dev/null
+++ b/meta-ti-extras/conf/layer.conf
@@ -0,0 +1,33 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://qt.digia.com/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb \
+            ${LAYERDIR}/recipes*/*/*.bbappend \
+            "
+
+BBFILE_COLLECTIONS += "b2qt_ti"
+BBFILE_PATTERN_b2qt_ti := "^${LAYERDIR}/"
+BBFILE_PRIORITY_b2qt_ti = "20"
diff --git a/recipes/libgles/libgles-omap3/rc.pvr b/meta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr
similarity index 100%
rename from recipes/libgles/libgles-omap3/rc.pvr
rename to meta-ti-extras/recipes/libgles/libgles-omap3/rc.pvr
diff --git a/recipes/libgles/libgles-omap3_4.09.00.01.bbappend b/meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
similarity index 100%
rename from recipes/libgles/libgles-omap3_4.09.00.01.bbappend
rename to meta-ti-extras/recipes/libgles/libgles-omap3_4.09.00.01.bbappend
diff --git a/recipes/libgles/libgles-omap3_4.10.00.01.bb b/meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
similarity index 100%
rename from recipes/libgles/libgles-omap3_4.10.00.01.bb
rename to meta-ti-extras/recipes/libgles/libgles-omap3_4.10.00.01.bb
diff --git a/recipes/libgles/libgles-omap3_5.01.01.01.bbappend b/meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
similarity index 100%
rename from recipes/libgles/libgles-omap3_5.01.01.01.bbappend
rename to meta-ti-extras/recipes/libgles/libgles-omap3_5.01.01.01.bbappend
diff --git a/recipes/linux/linux-am335x-psp_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
similarity index 100%
rename from recipes/linux/linux-am335x-psp_3.2.bbappend
rename to meta-ti-extras/recipes/linux/linux-am335x-psp_3.2.bbappend
diff --git a/recipes/linux/linux-mainline_3.2.bbappend b/meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
similarity index 100%
rename from recipes/linux/linux-mainline_3.2.bbappend
rename to meta-ti-extras/recipes/linux/linux-mainline_3.2.bbappend
diff --git a/recipes/linux/linux-ti-staging/usb-serial.cfg b/meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg
similarity index 100%
rename from recipes/linux/linux-ti-staging/usb-serial.cfg
rename to meta-ti-extras/recipes/linux/linux-ti-staging/usb-serial.cfg
diff --git a/recipes/linux/linux-ti-staging_3.12.bbappend b/meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend
similarity index 100%
rename from recipes/linux/linux-ti-staging_3.12.bbappend
rename to meta-ti-extras/recipes/linux/linux-ti-staging_3.12.bbappend
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
similarity index 100%
rename from recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
rename to meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/0001-Graphics-SDK-04.10.00.01-AM335x-sgx-irq-change.patch
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
similarity index 100%
rename from recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
rename to meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/Change-for-interfacing-with-SGX-DT-node.patch
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
similarity index 100%
rename from recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
rename to meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules/linux-3.8.patch
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb b/meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
similarity index 100%
rename from recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
rename to meta-ti-extras/recipes/powervr-drivers/omap3-sgx-modules_4.10.00.01.bb
diff --git a/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch b/meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch
similarity index 100%
rename from recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch
rename to meta-ti-extras/recipes/u-boot/u-boot-am33x/0001-am335x-evm-disable-console-cursor-blinking.patch
diff --git a/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend b/meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
similarity index 100%
rename from recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
rename to meta-ti-extras/recipes/u-boot/u-boot-am33x_2013.01.01.bbappend
diff --git a/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
similarity index 100%
rename from recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
rename to meta-ti-extras/recipes/u-boot/u-boot-ti-staging/0001-BBB-disable-console-cursor-blinking.patch
diff --git a/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend b/meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
similarity index 100%
rename from recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
rename to meta-ti-extras/recipes/u-boot/u-boot-ti-staging_2013.10.bbappend
-- 
GitLab