diff --git a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch b/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
deleted file mode 100644
index ed58b5026d54e374ea758c816f8bd37a2105b170..0000000000000000000000000000000000000000
--- a/recipes/systemd/systemd/0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 6a7105e23d8be76094b90d814eab9135e2cc4b8a Mon Sep 17 00:00:00 2001
-From: Gatis Paeglis <gatis.paeglis@qt.io>
-Date: Tue, 21 Jun 2016 15:26:47 +0200
-Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
- mounts too"
-
-This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
----
- src/core/mount.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/core/mount.c b/src/core/mount.c
-index fda4d65..3944232 100644
---- a/src/core/mount.c
-+++ b/src/core/mount.c
-@@ -337,7 +337,7 @@ static int mount_add_device_links(Mount *m) {
- 
-         assert(m);
- 
--        p = get_mount_parameters(m);
-+        p = get_mount_parameters_fragment(m);
-         if (!p)
-                 return 0;
- 
--- 
-2.7.4
-
diff --git a/recipes/systemd/systemd_%.bbappend b/recipes/systemd/systemd_%.bbappend
index 4dce1b2eb8e28d48340cbfe373f5ee3c293e639d..1ba27feee648877f9d814593fe8ac31375aa076d 100644
--- a/recipes/systemd/systemd_%.bbappend
+++ b/recipes/systemd/systemd_%.bbappend
@@ -29,7 +29,6 @@
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 SRC_URI += " \
-    file://0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch \
     file://usb-rndis.network \
 "
 
@@ -42,11 +41,3 @@ do_install_append() {
     install -d ${D}${prefix}/lib/systemd/network/
     install -m 0644 ${WORKDIR}/usb-rndis.network ${D}${prefix}/lib/systemd/network/
 }
-
-do_verify_patch_required() {
-    if [ -n "$(cat ${S}/NEWS | grep "CHANGES WITH 229")" ]; then
-        bbwarn "systemd: The 0020-Revert-core-mount-add-dependencies-to-dynamically-mo.patch patch is not required anymore."
-    fi
-}
-
-addtask do_verify_patch_required after do_fetch before do_configure