From 20a3734c0da057a51aadc89e3dba163367611dc5 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@digia.com>
Date: Thu, 23 Jan 2014 13:36:37 +0200
Subject: [PATCH] upgrade emulator components

- kernel 3.10
- LLVM 3.3
- mesa 9.1.6

Change-Id: Ib15c6826ab480e39e4efb7a16d42030b55ad6c3b
Reviewed-by: Samuli Piippo <samuli.piippo@digia.com>
---
 classes/image-hdd.bbclass                     |  19 +-
 conf/distro/include/emulator.conf             |   2 +-
 conf/machine/emulator.conf                    |   1 -
 ...3.8.bbappend => linux-yocto_3.10.bbappend} |   3 +-
 recipes/llvm/llvm-common.bb                   |  44 ----
 recipes/llvm/llvm-common/llvm-config          |  10 -
 recipes/llvm/llvm.inc                         | 226 ------------------
 recipes/llvm/llvm3.2/arm_fenv_uclibc.patch    |  14 --
 recipes/llvm/llvm3.2_3.2.bb                   | 127 ----------
 recipes/mesa/mesa_9.1.6.bbappend              |   6 +
 10 files changed, 11 insertions(+), 441 deletions(-)
 rename recipes/linux/{linux-yocto_3.8.bbappend => linux-yocto_3.10.bbappend} (92%)
 delete mode 100644 recipes/llvm/llvm-common.bb
 delete mode 100644 recipes/llvm/llvm-common/llvm-config
 delete mode 100644 recipes/llvm/llvm.inc
 delete mode 100644 recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
 delete mode 100644 recipes/llvm/llvm3.2_3.2.bb
 create mode 100644 recipes/mesa/mesa_9.1.6.bbappend

diff --git a/classes/image-hdd.bbclass b/classes/image-hdd.bbclass
index 123c4175..fb59c205 100644
--- a/classes/image-hdd.bbclass
+++ b/classes/image-hdd.bbclass
@@ -29,32 +29,17 @@ SYSLINUX_PROMPT = "0"
 SYSLINUX_TIMEOUT = "1"
 SYSLINUX_LABELS = "boot"
 LABELS_append = " ${SYSLINUX_LABELS} "
+SYSLINUX_DEFAULT_CONSOLE = "console=ttyS0,115200"
 
 inherit image_types boot-directdisk
 
 create_hdd_image () {
-	ln -s ${IMAGE_NAME}.hdddirect ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.hdd
+	ln -fs ${IMAGE_NAME}.hdddirect ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.hdd
 }
 
 python do_hddimg() {
         bb.build.exec_func('create_hdd_image', d)
 }
 
-python build_syslinux_cfg_append () {
-    import re
-
-    try:
-        cfgfile = file(cfile, 'r+')
-    except OSError:
-        raise bb.build.funcFailed('Unable to open %s' % (cfile))
-
-    f_content = cfgfile.read()
-    f_content = re.sub('tty0', 'ttyS0,115200', f_content)
-
-    cfgfile.seek(0)
-    cfgfile.write(f_content)
-    cfgfile.close()
-}
-
 addtask hddimg after do_bootdirectdisk before do_build
 do_hddimg[nostamp] = "1"
diff --git a/conf/distro/include/emulator.conf b/conf/distro/include/emulator.conf
index ce170523..d3d5efdc 100644
--- a/conf/distro/include/emulator.conf
+++ b/conf/distro/include/emulator.conf
@@ -32,7 +32,7 @@ MACHINE_EXTRA_RRECOMMENDS += "\
 kernel_autoload_snd-intel8x0 = "snd-intel8x0"
 
 MACHINE_EXTRA_INSTALL = "\
-        llvm3.2 \
+        llvm3.3 \
         libegl-mesa \
         libegl-gallium \
         libgles2-mesa \
diff --git a/conf/machine/emulator.conf b/conf/machine/emulator.conf
index 2aac3aba..f2628d5a 100644
--- a/conf/machine/emulator.conf
+++ b/conf/machine/emulator.conf
@@ -29,7 +29,6 @@ PREFERRED_PROVIDER_virtual/libgles1 ?= "mesa"
 PREFERRED_PROVIDER_virtual/libgles2 ?= "mesa"
 
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
-PREFERRED_VERSION_linux-yocto ?= "3.8%"
 
 require conf/machine/include/tune-i586.inc
 
diff --git a/recipes/linux/linux-yocto_3.8.bbappend b/recipes/linux/linux-yocto_3.10.bbappend
similarity index 92%
rename from recipes/linux/linux-yocto_3.8.bbappend
rename to recipes/linux/linux-yocto_3.10.bbappend
index fa6d5ebd..9cd7e692 100644
--- a/recipes/linux/linux-yocto_3.8.bbappend
+++ b/recipes/linux/linux-yocto_3.10.bbappend
@@ -25,4 +25,5 @@ SRC_URI += "\
     file://snd_intel8x0.cfg \
     "
 
-COMPATIBLE_MACHINE += "|emulator"
+KMACHINE_emulator = "qemux86"
+COMPATIBLE_MACHINE_emulator = "emulator"
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
deleted file mode 100644
index 0e206004..00000000
--- a/recipes/llvm/llvm-common.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-#############################################################################
-##
-## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
-##
-## This file is part of the Qt Enterprise Embedded Scripts of the Qt
-## framework.
-##
-## $QT_BEGIN_LICENSE$
-## Commercial License Usage Only
-## Licensees holding valid commercial Qt license agreements with Digia
-## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
-## may use this file in accordance with the terms contained in said license
-## agreement.
-##
-## For further information use the contact form at
-## http://qt.digia.com/contact-us.
-##
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-DESCRIPTION = "Helper script for OE's llvm support"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
-"
-
-SRC_URI = "file://llvm-config"
-
-ALLOW_EMPTY_${PN} = "1"
-SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_common_sysroot_preprocess"
-
-llvm_common_sysroot_preprocess() {
-    install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
-    install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
-}
-
-do_install_virtclass-native() {
-    install -d ${D}${bindir}
-    install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
-}
-
-BBCLASSEXTEND = "native"
diff --git a/recipes/llvm/llvm-common/llvm-config b/recipes/llvm/llvm-common/llvm-config
deleted file mode 100644
index a9a416d9..00000000
--- a/recipes/llvm/llvm-common/llvm-config
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-# Wrapper script for real llvm-config. Simply calls
-
-if [ $WANT_LLVM_RELEASE ]; then
-	exec `dirname $0`/${TARGET_PREFIX}llvm-config$WANT_LLVM_RELEASE ${@}
-else
-  echo "The variable WANT_LLVM_RELEASE is not defined and exported"
-	echo "by your build recipe. Go figure."
-  exit 1
-fi
diff --git a/recipes/llvm/llvm.inc b/recipes/llvm/llvm.inc
deleted file mode 100644
index fcd26668..00000000
--- a/recipes/llvm/llvm.inc
+++ /dev/null
@@ -1,226 +0,0 @@
-# LLVM does not provide ABI stability between different versions. For this
-# reason OE makes it possible to build and install different llvm versions
-# at the same time.
-#
-# This is true for the normal recipes as well as the native ones.
-#
-# All regular installation directories are prefixed with 'llvm${LLVM_RELEASE}'
-# e.g. "${STAGING_BINDIR}/llvm2.5" or "${STAGING_INCDIR}/llvm2.5"
-#
-# For your program or library that makes use of llvm you do should not need to
-# modify anything as long as it uses the results of various llvm-config
-# invocations. If you need customizations something is wrong and it needs to be
-# fixed (report bug).
-#
-# However the *recipe* for your program/library *must* declare
-# export WANT_LLVM_RELEASE = "<valid version number>"
-# The version number is picked up by a generic wrapper script which just calls
-# the variant of the specified version.
-
-DESCRIPTION = "The Low Level Virtual Machine"
-HOMEPAGE = "http://llvm.org"
-# 3-clause BSD-like
-LICENSE = "NCSA"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855"
-
-DEPENDS = "llvm${LLVM_RELEASE}-native llvm-common"
-DEPENDS_virtclass-native = "llvm-common-native cmake-native"
-
-INC_PR = "r2"
-
-SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.tgz"
-
-S = "${WORKDIR}/llvm-${PV}"
-
-inherit cmake perlnative pythonnative
-
-# Defines the LLVM supported arches. By now we always build either for ${BUILD}
-# (native) or ${TARGET}. In the future it may make sense to enable all backends
-# for the non-native build. The decision which backends are used is made by
-# the 3rd party program or library that uses llvm anyway.
-LLVM_ARCH = "${@get_llvm_arch(d)}"
-
-# This is used for generating the install directory for the llvm libraries,
-# binaries and headers. It makes side by side installation of those possible.
-LLVM_RELEASE = "${PV}"
-
-# llvm *must* be built out of tree
-OECMAKE_SOURCEPATH = ".."
-OECMAKE_BUILDPATH = "build"
-EXTRA_OECMAKE = "\
-    -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm${LLVM_RELEASE}/tblgen \
-    -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
-    -DCMAKE_LINKER:FILEPATH=${LD} \
-    -DCMAKE_AR:FILEPATH=${AR} \
-    -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
-    -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
-    -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
-    -DCMAKE_STRIP:FILEPATH=${STRIP} \
-    -DNM_PATH:FILEPATH=${NM} \
-    -DLLVM_ENABLE_PIC:BOOL=ON \
-    -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
-    -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
-    -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
-    -DBUILD_SHARED_LIBS:BOOL=ON \
-    -DCMAKE_SKIP_BUILD_RPATH:BOOL=ON \
-"
-# We need to reset this to avoid breakage as we build out of tree
-TOOLCHAIN_OPTIONS = ""
-
-PACKAGES_DYNAMIC = "llvm-*"
-
-# the difference to the non-native build is that we do not need
-# to declare the location of the tblgen executable.
-EXTRA_OECMAKE_virtclass-native = "\
-    -DLLVM_TARGETS_TO_BUILD=${LLVM_ARCH} \
-    -DCMAKE_LINKER:FILEPATH=${LD} \
-    -DCMAKE_AR:FILEPATH=${AR} \
-    -DCMAKE_OBJCOPY:FILEPATH=${OBJCOPY} \
-    -DCMAKE_OBJDUMP:FILEPATH=${OBJDUMP} \
-    -DCMAKE_RANLIB:FILEPATH=${RANLIB} \
-    -DCMAKE_STRIP:FILEPATH=${STRIP} \
-    -DNM_PATH:FILEPATH=${NM} \
-"
-
-PACKAGES_virtclass-native = ""
-
-PACKAGES_DYNAMIC_virtclass-native = ""
-
-python populate_packages_prepend () {
-    libllvm_libdir = bb.data.expand('${libdir}/llvm${LLVM_RELEASE}', d)
-    do_split_packages(d, libllvm_libdir, '^lib(.*)\.so$', 'libllvm-%s', 'Split package for %s', allow_dirs=True)
-}
-
-FILES_${PN} = ""
-ALLOW_EMPTY_${PN} = "1"
-
-FILES_${PN}-dbg += "${libdir}/llvm${LLVM_RELEASE}/.debug ${bindir}/llvm${LLVM_RELEASE}/.debug"
-
-FILES_${PN}-dev = " \
-                   ${includedir} \
-                   ${bindir}/* \
-                   ${libdir}/llvm${LLVM_RELEASE}/LLVMHello.so \
-                   ${libdir}/llvm${LLVM_RELEASE}/BugpointPasses.so \
-                   ${libdir}/llvm${LLVM_RELEASE}/*.a \
-"
-
-base_do_compile_prepend() {
-    # Avoid *** No rule to make target `native/bin/tblgen', needed by `include/llvm/Intrinsics.gen.tmp'
-    oe_runmake tblgen
-}
-
-do_install() {
-    # Install into a private directory to be able to reorganize the files.
-
-    cd ${OECMAKE_BUILDPATH}
-
-    oe_runmake DESTDIR=${WORKDIR}/llvm-install install
-
-    # Create our custom target directories
-    install -d ${D}${bindir}/llvm${LLVM_RELEASE}
-    install -d ${D}${includedir}/llvm${LLVM_RELEASE}
-    install -d ${D}${libdir}/llvm${LLVM_RELEASE}
-
-    #    Move headers into their own directory
-    cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
-    ${D}${includedir}/llvm${LLVM_RELEASE}/
-    cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
-    ${D}${includedir}/llvm${LLVM_RELEASE}/
-
-    find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
-    install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
-
-    #    I dont know another way out. Binaries are installed into a special subdir
-    find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
-    install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
-
-    # LLVM does not install this by default.
-    install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
-
-        # we install it here unmodified for native and none native and overwrite it
-        # later for native case
-        install -d ${D}${bindir}
-        install -m 0755 bin/llvm-config ${D}${bindir}
-}
-
-SYSROOT_PREPROCESS_FUNCS_append_class-target = " llvm_sysroot_preprocess"
-
-llvm_sysroot_preprocess() {
-    cd ${OECMAKE_BUILDPATH}
-
-    # Fix the paths in the config script to make it find the binaries and
-    # library files. Doing so allows 3rd party configure scripts working
-    # unmodified.
-    sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
-        -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
-        -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
-        -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
-        bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
-
-        install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
-        install -m 0755 bin/llvm-config${LLVM_RELEASE} ${SYSROOT_DESTDIR}${bindir_crossscripts}
-}
-
-do_install_virtclass-native() {
-    # Install into a private directory to be able to reorganize the files.
-
-        cd ${OECMAKE_BUILDPATH}
-
-        oe_runmake DESTDIR=${WORKDIR}/llvm-install install
-
-    # Create our custom target directories
-    install -d ${D}${bindir}/llvm${LLVM_RELEASE}
-    install -d ${D}${includedir}/llvm${LLVM_RELEASE}
-    install -d ${D}${libdir}/llvm${LLVM_RELEASE}
-
-    #    Move headers into their own directory
-    cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm \
-    ${D}${includedir}/llvm${LLVM_RELEASE}/
-    cp -R ${WORKDIR}/llvm-install/${prefix}/include/llvm-c \
-    ${D}${includedir}/llvm${LLVM_RELEASE}/
-
-    find ${WORKDIR}/llvm-install/${prefix}/lib -name "*" -maxdepth 1 -exec \
-    install {} ${D}${libdir}/llvm${LLVM_RELEASE} \;
-
-    #    I dont know another way out. Binaries are installed into a special subdir
-    find ${WORKDIR}/llvm-install/${prefix}/bin -name "*" -maxdepth 1 -exec \
-    install {} ${D}${bindir}/llvm${LLVM_RELEASE} \;
-
-    # LLVM does not install this by default.
-    install bin/tblgen ${D}${bindir}/llvm${LLVM_RELEASE}
-
-    # Fix the paths in the config script to make it find the binaries and
-    # library files. Doing so allows 3rd party configure scripts working
-    # unmodified.
-    sed -e's!my.*ABS_RUN_DIR =.*!my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";!' \
-        -e's!my.*INCLUDEDIR =.*!my $INCLUDEDIR = "${STAGING_INCDIR}/llvm${LLVM_RELEASE}";!' \
-        -e's!my.*LIBDIR.*!my $LIBDIR = "${STAGING_LIBDIR}/llvm${LLVM_RELEASE}";!' \
-        -e's!my.*BINDIR.*!my $BINDIR = "${STAGING_BINDIR}/llvm${LLVM_RELEASE}";!' \
-        bin/llvm-config > bin/llvm-config${LLVM_RELEASE}
-
-        install -d ${D}${bindir}
-        install -m 0755 bin/llvm-config${LLVM_RELEASE} ${D}${bindir}
-}
-
-
-# Retrieve the target in a way that is compatible to the arch
-# value in llvm (>= 2.5)
-def get_llvm_arch(d):
-    import bb;
-
-    arch = bb.data.getVar('TARGET_ARCH', d, 1)
-    if arch == "x86_64" or arch == "i486" or arch == "i586" or arch == "i686":
-        arch = "X86"
-    elif arch == "arm":
-        arch = "ARM"
-    elif arch == "mipsel" or arch == "mips":
-        arch = "mips"
-    elif arch == "powerpc" or arch == "powerpc64":
-        arch = "PowerPC"
-    else:
-        bb.warn("%s does not support %s yet" % (bb.data.getVar('PN', d, 1), arch) );
-
-    return arch
-
-BBCLASSEXTEND = "native"
-
diff --git a/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch b/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
deleted file mode 100644
index c3ae4946..00000000
--- a/recipes/llvm/llvm3.2/arm_fenv_uclibc.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: llvm-2.9/include/llvm/Support/FEnv.h
-===================================================================
---- llvm-2.9.orig/include/llvm/Support/FEnv.h	2010-11-29 20:44:50.000000000 +0100
-+++ llvm-2.9/include/llvm/Support/FEnv.h	2011-11-18 18:42:22.580161297 +0100
-@@ -17,6 +17,9 @@
- 
- #include "llvm/Config/config.h"
- #include <cerrno>
-+
-+#undef HAVE_FENV_H
-+
- #ifdef HAVE_FENV_H
- #include <fenv.h>
- #endif
diff --git a/recipes/llvm/llvm3.2_3.2.bb b/recipes/llvm/llvm3.2_3.2.bb
deleted file mode 100644
index 92b62f95..00000000
--- a/recipes/llvm/llvm3.2_3.2.bb
+++ /dev/null
@@ -1,127 +0,0 @@
-#############################################################################
-##
-## Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
-##
-## This file is part of the Qt Enterprise Embedded Scripts of the Qt
-## framework.
-##
-## $QT_BEGIN_LICENSE$
-## Commercial License Usage Only
-## Licensees holding valid commercial Qt license agreements with Digia
-## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
-## may use this file in accordance with the terms contained in said license
-## agreement.
-##
-## For further information use the contact form at
-## http://qt.digia.com/contact-us.
-##
-##
-## $QT_END_LICENSE$
-##
-#############################################################################
-
-DESCRIPTION = "The Low Level Virtual Machine"
-HOMEPAGE = "http://llvm.org"
-# 3-clause BSD-like
-LICENSE = "NCSA"
-LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=60fdd7739841f04a2ce2171a726be8f3"
-
-DEPENDS = "libffi libxml2-native llvm-common"
-
-SRC_URI = "http://llvm.org/releases/${PV}/llvm-${PV}.src.tar.gz"
-SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
-
-SRC_URI[md5sum] = "71610289bbc819e3e15fdd562809a2d7"
-SRC_URI[sha256sum] = "125090c4d26740f1d5e9838477c931ed7d9ad70d599ba265f46f3a42cb066343"
-
-S = "${WORKDIR}/llvm-${PV}.src"
-
-inherit autotools perlnative pythonnative
-
-LLVM_BUILD_DIR = "${WORKDIR}/llvm-${PV}.build"
-LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install"
-LLVM_DIR = "llvm${PV}"
-
-EXTRA_OECONF += "--disable-assertions \
-                 --enable-debug-runtime \
-                 --disable-expensive-checks \
-                 --enable-bindings=none \
-                 --enable-keep-symbols \
-                 --enable-libffi \
-                 --enable-optimized \
-                 --enable-shared \
-                 --enable-targets=host-only"
-EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
-FILES_${PN} = "${libdir}/lib*.so \
-               ${libdir}/${LLVM_DIR}/*"
-FILES_${PN}-dbg = "${bindir}/${LLVM_DIR}/.debug \
-                   ${libdir}/${LLVM_DIR}/.debug \
-                   ${libdir}/.debug \
-                   /usr/src/debug"
-FILES_${PN}-dev = "${bindir}/${LLVM_DIR} \
-                   ${includedir}/${LLVM_DIR} \
-                   ${libdir}/${LLVM_DIR}/BugpointPasses.so \
-                   ${libdir}/${LLVM_DIR}/LLVMHello.so"
-FILES_${PN}-static-dev = "${libdir}/${LLVM_DIR}/*.a"
-FILES_SOLIBSDEV = ""
-INSANE_SKIP_${PN} = "dev-so"
-
-do_configure_prepend() {
-	# Remove RPATHs
-	sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules
-
-	# Drop "svn" suffix from version string
-	sed -i 's/3\.2svn/3.2/g' configure
-
-	# Fix paths in llvm-config
-	sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp
-	sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp
-
-	# Fails to build unless using separate directory from source
-	mkdir -p ${LLVM_BUILD_DIR}
-	cd ${LLVM_BUILD_DIR}
-}
-
-do_compile() {
-	cd ${LLVM_BUILD_DIR}
-	oe_runmake \
-		AR="${BUILD_AR}" \
-		CC="${BUILD_CC}" \
-		CFLAGS="${BUILD_CFLAGS}" \
-		CXX="${BUILD_CXX}" \
-		CXXFLAGS="${BUILD_CXXFLAGS}" \
-		CPP="${BUILD_CPP}" \
-		CPPFLAGS="${BUILD_CPPFLAGS}" \
-		NM="${BUILD_NM}" \
-		RANLIB="${BUILD_RANLIB}" \
-		PATH="${STAGING_BINDIR_NATIVE}:$PATH" \
-		cross-compile-build-tools
-	oe_runmake
-}
-
-do_install() {
-	cd ${LLVM_BUILD_DIR}
-	oe_runmake DESTDIR=${LLVM_INSTALL_DIR} install
-
-	mv ${LLVM_INSTALL_DIR}${bindir}/${HOST_SYS}-llvm-config-host ${LLVM_INSTALL_DIR}/llvm-config-host
-
-	install -d ${D}${bindir}/${LLVM_DIR}
-	mv ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/
-
-	install -d ${D}${includedir}/${LLVM_DIR}
-	mv ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/
-
-	install -d ${D}${libdir}/${LLVM_DIR}
-	mv ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/
-	ln -s ${LLVM_DIR}/libLLVM-${PV}.so ${D}${libdir}/libLLVM-${PV}.so
-
-	install -d ${D}${docdir}/${LLVM_DIR}
-	mv ${LLVM_INSTALL_DIR}${prefix}/docs/llvm/* ${D}${docdir}/${LLVM_DIR}
-}
-
-SYSROOT_PREPROCESS_FUNCS += "llvm_sysroot_preprocess"
-
-llvm_sysroot_preprocess() {
-	install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}
-	mv ${LLVM_INSTALL_DIR}/llvm-config-host ${SYSROOT_DESTDIR}${bindir_crossscripts}/llvm-config${PV}
-}
diff --git a/recipes/mesa/mesa_9.1.6.bbappend b/recipes/mesa/mesa_9.1.6.bbappend
new file mode 100644
index 00000000..6c11709d
--- /dev/null
+++ b/recipes/mesa/mesa_9.1.6.bbappend
@@ -0,0 +1,6 @@
+EGL_PLATFORMS = "fbdev"
+PACKAGECONFIG = "egl gles dri gallium gallium-llvm gallium-egl"
+GALLIUMDRIVERS_LLVM = ""
+DRIDRIVERS_remove = "swrast,radeon,r200,nouveau,i965,i915"
+DRIDRIVERS_append += "swrast"
+EXTRA_OECONF += "--with-dri-drivers="""
-- 
GitLab