From 29bf06b9b89c600c6de8a33c1e60b5b946e51a1e Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Mon, 18 Jan 2016 12:03:15 +0200
Subject: [PATCH] ninja-native: add recipe from meta-qt5

ninja-native was removed from meta-qt5 and it was moved to meta-oe
(master and jethro). We are still using fido, so we need to add the
recipe here.

Change-Id: Ia77030d189b5c1112391d3e537feeea52fc0ab8d
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
---
 recipes/ninja/ninja-native_git.bb | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 recipes/ninja/ninja-native_git.bb

diff --git a/recipes/ninja/ninja-native_git.bb b/recipes/ninja/ninja-native_git.bb
new file mode 100644
index 00000000..e2deb6b2
--- /dev/null
+++ b/recipes/ninja/ninja-native_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Ninja is a small build system with a focus on speed."
+LICENSE = "Apache-2"
+
+inherit native
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
+
+PV = "1.5.3+gitr${SRCPV}"
+SRCREV="3309498174411e02e7680ea8b470bb7d1d70bdb8"
+SRCBRANCH="release"
+
+SRC_URI = "git://github.com/martine/ninja.git;branch=${SRCBRANCH}"
+
+S="${WORKDIR}/git"
+
+do_compile() {
+    python ${S}/bootstrap.py
+}
+
+do_install() {
+    install -d ${D}${bindir}
+    install -m 0755 ${S}/ninja ${D}${bindir}/ninja
+}
-- 
GitLab