diff --git a/conf/distro/include/raspberrypi2.conf b/conf/distro/include/raspberrypi2.conf
index 040ea9b78dc8df9ed40371f5bab560b9cc7cdacc..392ce405636e8175b25f1623a879ed70b6480bf4 100644
--- a/conf/distro/include/raspberrypi2.conf
+++ b/conf/distro/include/raspberrypi2.conf
@@ -46,7 +46,7 @@ module_conf_bcm2835-v4l2 = "options bcm2835-v4l2 gst_v4l2src_is_broken=1"
 GPU_MEM = "256"
 # video camera support
 VIDEO_CAMERA = "1"
-RPI_FT5604 = "1"
+RPI_FT5406 = "1"
 
 KERNEL_DEVICETREE += "overlays/rpi-ft5406-overlay.dtb"
 MACHINE_FEATURES += "pitft"
diff --git a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
index b711ab519d9c0a4b91806ffca4c3321ec1fc1edf..da7a7b543540b702d8411db40fed7ea253cfd88f 100644
--- a/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
+++ b/meta-raspberrypi-extras/recipes/bootfiles/rpi-config_git.bbappend
@@ -20,8 +20,8 @@
 ##############################################################################
 
 do_deploy_append() {
-    if [ "${RPI_FT5604}" = "1" ]; then
-        echo "# Enable rpi-ft5604 touch" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+    if [ "${RPI_FT5406}" = "1" ]; then
+        echo "# Enable rpi-ft5406 touch" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
         echo "dtoverlay=rpi-ft5406" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
     fi
 }