diff --git a/recipes-qt/qt5-addons/qtquickcompiler_3.0.bb b/recipes-qt/qt5-addons/qtquickcompiler_git.bb
similarity index 93%
rename from recipes-qt/qt5-addons/qtquickcompiler_3.0.bb
rename to recipes-qt/qt5-addons/qtquickcompiler_git.bb
index 6226e6eb5a8089ffb9af64f7fea34898ca9d9e57..1bd37e661a5ad045a4acb1b899ad76e6b57f8edd 100644
--- a/recipes-qt/qt5-addons/qtquickcompiler_3.0.bb
+++ b/recipes-qt/qt5-addons/qtquickcompiler_git.bb
@@ -30,9 +30,9 @@ SRC_URI = " \
     git://codereview.qt-project.org/qt/tqtc-qmlcompiler;branch=${BRANCH};protocol=ssh \
     "
 
-# v3.0.0
-SRCREV = "7e29e55c8315cc5e944505f13c24893d0f54efeb"
-BRANCH = "3.0"
+# v5.6.0
+SRCREV = "07aeee460cc170eef28c05ce13aa30408f558215"
+BRANCH = "5.6"
 
 S = "${WORKDIR}/git"
 
diff --git a/recipes-qt/qt5/qt3d/0001-Remove-qgltf.patch b/recipes-qt/qt5/qt3d/0001-Remove-qgltf.patch
new file mode 100644
index 0000000000000000000000000000000000000000..48a4085ea061b1d9d70bfce893b03f516a363a20
--- /dev/null
+++ b/recipes-qt/qt5/qt3d/0001-Remove-qgltf.patch
@@ -0,0 +1,25 @@
+From 49a04f4faa135fa6ef56fc35dfb9dfe55ff2a3c4 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@theqtcompany.com>
+Date: Wed, 18 Nov 2015 10:14:18 +0200
+Subject: [PATCH] Remove qgltf
+
+assimp does not compile for ARM because of GCC bug
+(https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66964)
+
+Task-number: QTBUG-49153
+---
+ tools/tools.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/tools.pro b/tools/tools.pro
+index 055f412..c1eba7f 100644
+--- a/tools/tools.pro
++++ b/tools/tools.pro
+@@ -1,3 +1,3 @@
+ TEMPLATE = subdirs
+-SUBDIRS = qgltf
++#SUBDIRS = qgltf
+ qgltf.CONFIG += host_build
+-- 
+1.9.1
+
diff --git a/recipes-qt/qt5/qt3d_git.bbappend b/recipes-qt/qt5/qt3d_git.bbappend
new file mode 100644
index 0000000000000000000000000000000000000000..c7fa7666bde9684868fbfc07dcd7b737432bf12a
--- /dev/null
+++ b/recipes-qt/qt5/qt3d_git.bbappend
@@ -0,0 +1,27 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+    file://0001-Remove-qgltf.patch \
+    "
diff --git a/scripts/manifest.xml b/scripts/manifest.xml
index 9fc0bf6a75ef96e660f2862a624b4d17e8629a4f..53ed620c6885a34791923fa92f3fb4a1ea17e329 100644
--- a/scripts/manifest.xml
+++ b/scripts/manifest.xml
@@ -22,7 +22,7 @@
            path="sources/meta-openembedded"/>
   <project name="meta-qt5"
            remote="meta-qt5"
-           revision="89038bffd224a0d43aa8627472374503b3023f61"
+           revision="4f208863257768b875378af1421d33f1d6cf8a05"
            path="sources/meta-qt5"/>
 
   <project name="meta-fsl-arm"