diff --git a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
index a464a22ff3d39c0ae45de952a580be44426053cf..018586aaa5d10de29b552e80dc5ab65fb7817337 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/nativesdk-qtbase_git.bbappend
@@ -36,8 +36,6 @@ SRC_URI += "\
 PACKAGECONFIG += "openssl gui imageformats"
 PACKAGECONFIG_remove_mingw32 += "openssl"
 
-PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
-
 fakeroot do_generate_qt_environment_file_mingw32() {
 }
 
diff --git a/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
index eecfa5a6987576d5e656095959c1129d011f92b2..c06ab32fb371b47da02b3e64573d9f679d62b8e3 100644
--- a/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt5/qtbase-native_git.bbappend
@@ -29,7 +29,8 @@
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/qtbase:"
 
-PACKAGECONFIG += "gui imageformats"
+PACKAGECONFIG += "openssl gui imageformats"
+PACKAGECONFIG_remove_mingw32 += "openssl"
 
 SRC_URI += "\
     file://0001-Add-win32-g-oe-mkspec-that-uses-the-OE_-environment.patch \
diff --git a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
index db9864670ee7cb9ac6d61bb51846c7d61719834a..0f85831ac97f70eb36d8d29e6253d2a305ea136a 100644
--- a/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
+++ b/meta-boot2qt/recipes-qt/automotive/qtapplicationmanager_git.bb
@@ -39,8 +39,7 @@ SRCREV = "3bc3dc4c8e912beb18aec7ab84af40c0129d84c0"
 DEPENDS = "qtbase qtdeclarative libyaml libarchive \
            ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland qtwayland-native", "", d)}"
 
-RDEPENDS_${PN} = "libcrypto ${PN}-tools"
-RDEPENDS_${PN}_remove_mingw32 = "libcrypto"
+RDEPENDS_${PN}_class-target = "libcrypto ${PN}-tools"
 
 EXTRA_QMAKEVARS_PRE += "\
     ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "-config force-multi-process", "-config force-single-process", d)} \
@@ -58,7 +57,7 @@ FILES_${PN} += "\
     /opt/am \
     "
 
-BBCLASSEXTEND += "nativesdk"
+BBCLASSEXTEND += "nativesdk native"
 
 # nativesdk-qtdeclarative is added only to make build deterministic, can be removed once
 # there is a configure option to disable its usage.
@@ -68,3 +67,6 @@ DEPENDS_class-nativesdk_remove_mingw32 = "nativesdk-glibc-locale nativesdk-libar
 EXTRA_QMAKEVARS_PRE_class-nativesdk = "\
     -config tools-only \
     "
+EXTRA_QMAKEVARS_PRE_class-native = "\
+    -config tools-only \
+    "