diff --git a/recipes/connman/connman_%.bbappend b/recipes/connman/connman_%.bbappend
new file mode 100644
index 0000000000000000000000000000000000000000..0b03755aff517c47c4523e0147f39ac7a2061d19
--- /dev/null
+++ b/recipes/connman/connman_%.bbappend
@@ -0,0 +1,24 @@
+##############################################################################
+##
+## Copyright (C) 2016 The Qt Company Ltd.
+## Contact: http://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:COMM$
+##
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see http://www.qt.io/terms-conditions. For further
+## information use the contact form at http://www.qt.io/contact-us.
+##
+## $QT_END_LICENSE$
+##
+##############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://0001-disable-connman-when-booting-over-nfs.patch"
diff --git a/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
new file mode 100644
index 0000000000000000000000000000000000000000..eefd6a3276df482aeee5f2cb5176255c7ade9d08
--- /dev/null
+++ b/recipes/connman/files/0001-disable-connman-when-booting-over-nfs.patch
@@ -0,0 +1,21 @@
+From ccc6013f1e55b67981fb336aba657aea1520aeda Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Tue, 20 Sep 2016 11:02:50 +0300
+Subject: [PATCH] Disable connman when booting over NFS
+
+---
+ src/connman.service.in | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/connman.service.in b/src/connman.service.in
+index 8f7f342..8470f91 100644
+--- a/src/connman.service.in
++++ b/src/connman.service.in
+@@ -3,6 +3,7 @@ Description=Connection service
+ After=dbus.service network-pre.target
+ Before=network.target remote-fs-pre.target
+ Wants=network.target remote-fs-pre.target
++ConditionKernelCommandLine=!root=/dev/nfs
+ 
+ [Service]
+ Type=dbus