diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
index 06c1c796d98505080324437c339f04f0e3dd0a05..287af3aa0f21cb61487d40463db12bb35e75babd 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt5-toolchain-target.bb
@@ -47,6 +47,7 @@ RDEPENDS_${PN} += " \
     qtmultimedia-dev \
     qtquickcontrols-dev \
     qtsensors-dev \
+    qtserialbus-dev \
     qtserialport-dev \
     qtsvg-dev \
     qttools-dev \
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
index 89093931ed50feb47346620c569cd71e22958894..4ab0fd6fbeb49c84fc4b32cd52fee62cbcecea28 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-qt5-modules.bb
@@ -43,6 +43,7 @@ RDEPENDS_${PN} += " \
     qtmultimedia \
     qtquickcontrols \
     qtsensors \
+    qtserialbus \
     qtserialport \
     qtsvg \
     qttools \
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
new file mode 100644
index 0000000000000000000000000000000000000000..215dcc485bef82f57c2c089ae0fd3760bbd494dc
--- /dev/null
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -0,0 +1,36 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+require recipes-qt/qt5/qt5.inc
+require recipes-qt/qt5/qt5-git.inc
+
+LICENSE = "GFDL-1.3 & (LGPL-3.0 | GPL-3.0 | GPL-2.1)"
+LIC_FILES_CHKSUM = " \
+    file://LICENSE.LGPLv3;md5=b8c75190712063cde04e1f41b6fdad98 \
+    file://LICENSE.GPLv2;md5=05832301944453ec79e40ba3c3cfceec \
+    file://LICENSE.GPLv3;md5=40f9bf30e783ddc201497165dfb32afb \
+    file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5 \
+"
+
+DEPENDS += "qtbase qtserialport"
+
+SRCREV = "09c85ebde76311ddf46413a38a023f0ffefa5a31"