From ff1cb4f603822798b052b9a781bd11b74a6a80f6 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Mon, 7 Dec 2015 15:14:49 +0200
Subject: [PATCH] Add recipe for Qt Web Browser

Change-Id: I2927568f49aeecef5d0622a90ea4fd75a66653e0
Reviewed-by: Teemu Holappa <teemu.holappa@theqtcompany.com>
---
 recipes-qt/automotive/qtwebbrowser_git.bb     | 41 +++++++++++++++++++
 .../packagegroup-b2qt-automotive-addons.bb    |  1 +
 2 files changed, 42 insertions(+)
 create mode 100644 recipes-qt/automotive/qtwebbrowser_git.bb

diff --git a/recipes-qt/automotive/qtwebbrowser_git.bb b/recipes-qt/automotive/qtwebbrowser_git.bb
new file mode 100644
index 00000000..036e2e6e
--- /dev/null
+++ b/recipes-qt/automotive/qtwebbrowser_git.bb
@@ -0,0 +1,41 @@
+#############################################################################
+##
+## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
+##
+## This file is part of the Qt Enterprise Embedded Scripts of the Qt
+## framework.
+##
+## $QT_BEGIN_LICENSE$
+## Commercial License Usage Only
+## Licensees holding valid commercial Qt license agreements with Digia
+## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
+## may use this file in accordance with the terms contained in said license
+## agreement.
+##
+## For further information use the contact form at
+## http://www.qt.io/contact-us.
+##
+##
+## $QT_END_LICENSE$
+##
+#############################################################################
+
+DESCRIPTION = "Qt Web Browser"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://src/main.cpp;md5=e78c6c33aa5ec2464456b72daf61ef9c;beginline=1;endline=36"
+
+inherit qmake5 sdk-sources
+
+SRC_URI = " \
+    git://codereview.qt-project.org/qt-apps/tqtc-qtwebbrowser;branch=${BRANCH};protocol=ssh;sdk-uri=5.6/Src/qtwebbrowser \
+    "
+
+SRCREV = "2e18b419a7084b1e39bf8749855768a1002e34de"
+BRANCH = "dev"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "qtbase qtdeclarative qtwebengine"
+
+FILES_${PN} += "/data/user/qt/qtwebbrowser"
+FILES_${PN}-dbg += "/data/user/qt/qtwebbrowser/.debug"
diff --git a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
index b680b1e0..a4b2d103 100644
--- a/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
+++ b/recipes-qt/packagegroups/packagegroup-b2qt-automotive-addons.bb
@@ -30,4 +30,5 @@ PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
 RDEPENDS_${PN} += " \
     b2qt-appcontroller \
     qtivi \
+    ${@base_contains('DISTRO_FEATURES', 'webengine', 'qtwebbrowser', '', d)} \
     "
-- 
GitLab